Last modified: 2010-05-15 15:56:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6564 - error 1054: Unknown column 'ipb_range_start' in 'where clause' (localhost)"
error 1054: Unknown column 'ipb_range_start' in 'where clause' (localhost)"
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
PC Windows Server 2003
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2006-07-06 09:18 UTC by Alastair Jones
Modified: 2010-05-15 15:56 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Alastair Jones 2006-07-06 09:18:07 UTC

im using mysql 5.0.22 as a backend for mediawiki latest rev. We already have a wiki in place but im 
changing servers and therefore im backing up the data from mysql v 4.1 and restoring it to a new 
mysql 5 installation on a different box. 

Im getting consistent errors however that I am sure to do with the dbase structure, though I could 
be completely wrong in this as my experience with both mysql and media wiki is 1 whole afternoon.. 

Im getting: 

A database query syntax error has occurred. This may indicate a bug in the software. The last 
attempted database query was: 
(SQL query hidden) 
from within function "Block::loadRange". MySQL returned error "1054: Unknown 
column 'ipb_range_start' in 'where clause' (localhost)". 

and having a google around im finding that its a problem with the way that 5 handles 4.1's data 
though there really isnt much on the net about this error.

This error occurs whenever I try to manipulate ('edit' discussion' etc) the data in any way - 
viewing is fine, but anything else is not. This error does NOT occur before I restore my data from 
mysql v 4.1

can you help? 


Alastair Jones 
Methodology Group
Comment 1 Rob Church 2006-07-08 11:32:20 UTC
You aren't changing MediaWiki version each time? Could you post a little bit
more information about what your process of migrating to and from 4.1/5.0
entails to allow reproduction of the error? Thanks.

Also, when you originally set up MediaWiki, did you select "backwards-compatible
UTF-8 handling", or are you using the experimental UTF-8 stuff?
Comment 2 Alastair Jones 2006-07-10 10:49:40 UTC

my legacy server runs:

MYSQL 4.1.11 server / 5.0.11 Client
Apache Http server 2.0.55
Media Wiki 1.5.2
and PHP, though I dont know what version - it would have been the latest available mid november last year (which is when this wiki 
went live)

my new server will run:
MYSQL 5.0.22 / client 5.0.4
IIS v 6 (server 2003 sp1)
Media Wiki 1.6.7 (Current stable rev)
PHP 5.1.4

all im doing to get the data from the old sql to the new is to backup the data to file, and the to restore it to the new DB. I am 
selecting the backup defaults when I dump the data out from the old box - these are:

Backup execution method - innoDB Online Backup
Output file soptions - SQL files / Add DROP statements / Complete INSERTS / Comment / Disable Keys.

I am following the install guide located at:

Though the second half of section 5 - adding of additional commands - fails.

The original mediawiki would have been setup with defaults and whatever was a recommended config at that time - the person that I 
have inherited this from knew as much about this subject as I do (though my knowledge is growing exponentially) and therefore 
wouldnt not have strayed from any default options.


Alastair Jones

Comment 3 Alastair Jones 2006-07-11 11:57:40 UTC

after dumping everything, I started again with a fresh install of mediawiki & PHP but this time using a new install of mysql 4.1 and a 
restore of the datsa from the production mysql server...I get the same error, so it would appear to not be a mysql error...


Comment 4 Antoine "hashar" Musso (WMF) 2006-07-11 16:35:22 UTC
Please run the maintenance/update.php script to upgrade
your database schema.

It can also be done by renaming LocalSettings.php and
redoing the installation (in case you dont have a shell
Comment 5 Alastair Jones 2006-07-13 10:31:50 UTC
yes - fantastic. this works. i create the wiki, restore my db, dump the local settings and let in upgrade the schema.

So (as im testing all this in a VM) i dump the machine, build another and start again so that I have a nice fresh install of everything without any hint of problems that I may have created by mucking around with it.

Only now I get:

MediaWiki 1.6.7 Installation
Don't forget security updates! Keep an eye on the low-traffic release announcements mailing list. 
Checking environment...
Please include all of the lines below when reporting installation problems.

Warning: dl() [function.dl]: Unable to load dynamic library './' - The specified module could not be found. in C:\mediawiki-1.6.7\ on line 19
Could not load MySQL driver! Please compile php --with-mysql or install the module. 

Every single time, yet I am doing nothing different from the first time I install and im following the same instructions. I have copied libmysql.dll into the PHP folder, and I even went and found a copy of php_mysql.dll and copied to same - no effect. so 
I copied everything from the PHP zip to C:\php and c:\mediawiki, and I stuck some components in system32 as another blog I found suggested the same.

still the same error. 

With every file in every location, this still doesnt work and its driving me nuts!....

alastair jones
Comment 6 Platonides 2006-10-01 14:15:15 UTC
Your last error is PHP related. You're not having mysql installed. On PHP5 mysql
extension is not enabled by default. See the manual but i give you the trick:
you need to edit your php.ini and uncomment the line for mysql ;)

Closing this old bug.

Note You need to log in before you can comment on or make changes to this bug.