Last modified: 2014-04-25 13:06:11 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 64421 - Allow to import modules from Wikidata/other chapter per require()
Allow to import modules from Wikidata/other chapter per require()
Status: RESOLVED DUPLICATE of bug 50329
Product: MediaWiki extensions
Classification: Unclassified
Lua (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Fran Rogers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-25 08:52 UTC by FelixReimann
Modified: 2014-04-25 13:06 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description FelixReimann 2014-04-25 08:52:44 UTC
Current situation: LUA source code of Module:Authority control is copied to other Wikipedias which want the same functionality. Copying modules will increase with the spread of LUA used for templates.

Design goal:
- One central LUA module which provides the basic functionality which is language independent and can be easily augmented/corrected in case of errors (perhaps on Wikidata)
- Each chapter includes the central module and adds language depended functionality (e.g., translations, local categories...)

Problem: Add the following module to the German Wikipedia:

local test = require('en:Module:Authority control')
p = {}
return p


Result:

=p
Lua-Error in package.lua, line 80: module `en:Module:Authority control' not found

Same for problem if you try to include a Wikidata module on a Wikipedia module

local test = require('wikidata:Module:CiteQ')
p = {}
return p

Result:
=p
Lua-Error in package.lua, Zeile 80: module `wikidata:Module:CiteQ' not found
Comment 1 Sam Reed (reedy) 2014-04-25 13:06:11 UTC

*** This bug has been marked as a duplicate of bug 50329 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links