Last modified: 2014-09-25 21:13:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 62899 - Build user interface for easily customizing a basic MediaWiki skin
Build user interface for easily customizing a basic MediaWiki skin
Status: RESOLVED DUPLICATE of bug 60317
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.23.0
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 27292
  Show dependency treegraph
 
Reported: 2014-03-21 00:02 UTC by Ioannis Protonotarios
Modified: 2014-09-25 21:13 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ioannis Protonotarios 2014-03-21 00:02:00 UTC
Appearance is most important for any site. Unfortunately, while MediaWiki is very advanced in functionality it lacks flexibility in terms of appearance. Vector skin is great, no doubt about it, but it seems there is no other alternative. Almost all wikis in the world look like Wikipedia. Of course one can apply their own CSS and customize the site's layout or even create their own skin in PHP but both solutions demand a lot of knowledge and effort and in the end nobody really does so exept maybe for some big commercial sites.

My proposal is the creation of a frontend that will help users with little or no experience at all to easily produce all the CSS needed to change their wiki's layout.

This is my proposal for GSoC 2014. Please leave your feedback here or the talk page of the proposal: https://www.mediawiki.org/wiki/User:Protnet/Frontend_for_Vector_skin_CSS_customizations
Comment 1 James Forrester 2014-09-01 15:35:13 UTC
Hmm. I see this bug request as more like asking for a variant of Wikia's "theme builder" (or whatever it's called) to make alterations on a specific skin, rather than a full custom skin builder.
Comment 2 Waldir 2014-09-25 21:13:06 UTC
(In reply to James Forrester from comment #1)
> Hmm. I see this bug request as more like asking for a variant of Wikia's
> "theme builder" (or whatever it's called) to make alterations on a specific
> skin, rather than a full custom skin builder.

I agree, and in that case this is a dupe of bug 60317.

*** This bug has been marked as a duplicate of bug 60317 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links