Last modified: 2014-05-15 22:49:46 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 61979 - Post-edit cookie does not properly clear when there is a custom domain
Post-edit cookie does not properly clear when there is a custom domain
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
JavaScript (Other open bugs)
1.23.0
All All
: Normal normal (vote)
: 1.24.0 release
Assigned To: Sam Smith
:
Depends on: 49156
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-27 01:24 UTC by Matthew Flaschen
Modified: 2014-05-15 22:49 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Matthew Flaschen 2014-02-27 01:24:19 UTC
This can be reproduced at https://wikitech.wikimedia.org/wiki/Sandbox , for instance.  I think this is because wikitech has a custom domain (not sure why, and I need to find the config).  The domain and path have to be set exactly the same when clearing the cookie.
Comment 1 Matthew Flaschen 2014-02-27 01:25:48 UTC
The symptom is that it shows the post-edit message every time you visit the page, until it expires.
Comment 2 Gerrit Notification Bot 2014-03-25 15:49:21 UTC
Change 120806 had a related patch set uploaded by Phuedx:
[WIP] Add the mw.cookie module

https://gerrit.wikimedia.org/r/120806
Comment 3 Gerrit Notification Bot 2014-03-31 15:26:24 UTC
Change 122423 had a related patch set uploaded by Phuedx:
Delete the post-edit cookie using the correct domain

https://gerrit.wikimedia.org/r/122423
Comment 4 Bartosz Dziewoński 2014-05-15 22:49:46 UTC
And merged. (Gerrit Notification Bot is currently down.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links