Last modified: 2014-02-20 18:50:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 61585 - new feature request: text balloons for internal links in wikipedia web browsing
new feature request: text balloons for internal links in wikipedia web browsing
Status: RESOLVED DUPLICATE of bug 503
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
wmf-deployment
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-20 11:11 UTC by E.Scribbler
Modified: 2014-02-20 18:50 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
illustration of proposed feature (250.60 KB, image/png)
2014-02-20 11:11 UTC, E.Scribbler
Details

Description E.Scribbler 2014-02-20 11:11:05 UTC
Created attachment 14634 [details]
illustration of proposed feature

Feature description
The best idea is just to look at the image I attached under "proposed feature", that explains it best. When viewing Wikipedia in the browser there are internal links to other Wikipedia articles. When the mouse cursor is put on a link the full link address is displayed. This sometimes helps, but not always. I would suggest that when the mouse is placed over a link (but not yet pressed) after a few seconds the first few lines of the linked article would appear like a small tooltip, not necessitating the reader to open that article in a new tab and so saving the reader time.

Specific example / use case
Example: Suppose I am reading the article about Cato the Younger and I see this sentence: 
"A noted orator, he is remembered for his stubbornness and tenacity (especially in his lengthy conflict with Julius Caesar) [...]".

If I don't know who Julius Caesar is but I don't want to open the article, just read a few lines to know the context, I can't. I have to open the article in a new tab. I propose that if I put the mouse over the link Julius Caesar, after a few seconds I would see in a tooltip or a small balloon the first lines of the linked article:
Gaius Julius Caesar[2] (Classical Latin: [ˈɡaː.i.ʊs ˈjuː.lɪ.ʊs ˈkaj.sar],[3] July 100 BC[4] – 15 March 44 BC)[5] was a Roman general, statesman, Consul, and notable author of Latin prose.

This way I don't have to open the article separately and I can move on with my reading.
Here's a visual example.

Proposed feature

(attached image 1)

Existing feature
It is similar to what is done today with links to references where you have a small balloon opening with the full name.

I hope this was clear. I would be happy to clarify with any other information needed.

Thank you and good day!
Comment 1 Bartosz Dziewoński 2014-02-20 11:13:59 UTC
Prateek and Yuvi are working on something very much like this, I think. :)
Comment 2 Bartosz Dziewoński 2014-02-20 11:15:18 UTC
There's some information and mockups (but not a lot :( ) available at
https://www.mediawiki.org/wiki/Extension:Popups and
https://www.mediawiki.org/wiki/Beta_Features/Hovercards#Current_beta_experiment_Designs
Comment 4 Bartosz Dziewoński 2014-02-20 18:50:13 UTC
I'll mark this as a dupe of an old outstanding very similar request to keep our Bugzilla clean. Thanks for the suggestion!

*** This bug has been marked as a duplicate of bug 503 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links