Last modified: 2014-03-04 19:48:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 61223 - run maintenance script to repair EducationProgram summary data
run maintenance script to repair EducationProgram summary data
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
wmf-deployment
All All
: High normal (vote)
: ---
Assigned To: Bryan Davis
: shell
Depends on:
Blocks: 16660
  Show dependency treegraph
 
Reported: 2014-02-11 17:47 UTC by Sage Ross
Modified: 2014-03-04 19:48 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sage Ross 2014-02-11 17:47:03 UTC
Bugs in earlier versions of the EducationProgram extension created incorrect summary data (which is redundant, built from other data). We've committed fixes for the causes of the incorrect data, and this maintenance script will update the summary data:

https://gerrit.wikimedia.org/r/#/c/110344/

As a start (to make sure it doesn't cause any unexpected issues) please run this maintenance script on test2.wikipedia.org.

After that, it should be run on all the production wikis that have the EducationProgram extension enabled. (The script should be part of 1.23wmf13, which is scheduled to hit the Wikipedias 2014-02-13.)
Comment 1 Andre Klapper 2014-02-25 16:39:04 UTC
Reedy / Greg: Could this be scheduled, please?
Comment 2 Greg Grossmeier 2014-03-03 17:39:01 UTC
https://wikitech.wikimedia.org/w/index.php?title=Deployments&diff=102380&oldid=102077

Tuesday March 4th at 19:00 UTC-ish.
Comment 3 Greg Grossmeier 2014-03-03 20:24:42 UTC
(In reply to Sage Ross from comment #0)
> After that, it should be run on all the production wikis that have the
> EducationProgram extension enabled.

Is there a list of these somewhere?
Comment 5 Bryan Davis 2014-03-04 19:46:57 UTC
Ran `mwscript extensions/EducationProgram/maintenance/fixSummaryData.php` against:
test2wiki, arwiki, cswiki, dewikiversity, elwiki, enwiki, enwikinews, eswiki, fawiki, hewiki, mkwiki, nlwiki, ptwiki and svwiki

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links