Last modified: 2014-03-12 07:00:38 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 61222 - Create wiki (legalteamwiki) for Wikimedia Foundation legal team
Create wiki (legalteamwiki) for Wikimedia Foundation legal team
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
wmf-deployment
All All
: Normal normal (vote)
: ---
Assigned To: This, that and the other (TTO)
: shell
Depends on:
Blocks: wikis-to-create
  Show dependency treegraph
 
Reported: 2014-02-11 17:46 UTC by James Alexander
Modified: 2014-03-12 07:00 UTC (History)
12 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description James Alexander 2014-02-11 17:46:09 UTC
In an effort to allow the legal and lca team to work directly on a wiki more often (including for legally sensitive work) and to move away from google docs and the like as much as possible we would like to set up a private wiki for the team.

In general Ombudsmanwiki would be a good wiki to copy settings from but for the ones I can think of off the top of my head:

Wiki domain should be legalwiki.wikimedia.org.
Language should be English.
Logo can be $stdlogo.
Favicon can be wmf.ico
Canonical server should be https (forced should be on).
Account creation should be bureaucrat only (not sysop).
Transwiki destinations of office, collab and meta would be helpful. (Not sure if private wikis can be tw destinations though... if not that's fine.
wmgUseDisableAccount should be true

I can be the original sysop/crat.
Comment 1 Kunal Mehta (Legoktm) 2014-02-11 17:49:43 UTC
(In reply to comment #0)

> Wiki domain should be legalwiki.wikimedia.org.

Why not legal.wikimedia.org?
Comment 2 Gerrit Notification Bot 2014-02-11 17:54:33 UTC
Change 112716 had a related patch set uploaded by Jforrester:
Add support for new private legalwiki

https://gerrit.wikimedia.org/r/112716
Comment 3 Gerrit Notification Bot 2014-02-11 17:56:36 UTC
Change 112717 had a related patch set uploaded by Jforrester:
Enable VisualEditor for legalwiki by default

https://gerrit.wikimedia.org/r/112717
Comment 4 James Forrester 2014-02-11 17:58:10 UTC
Above patches will allow VisualEditor support; it needs to be created first, however (obviously).
Comment 5 James Alexander 2014-02-11 18:07:52 UTC
(In reply to comment #1)
> (In reply to comment #0)
> 
> > Wiki domain should be legalwiki.wikimedia.org.
> 
> Why not legal.wikimedia.org?

To keep legal.wikimedia free incase it's wanted for something broader and more open then a confidential wiki.
Comment 6 MF-Warburg 2014-02-11 18:09:52 UTC
(In reply to comment #0)
> Transwiki destinations of office, collab and meta would be helpful. (Not sure
> if private wikis can be tw destinations though... if not that's fine.

I don't know that either but would guess that not. Even if, you'd have the problem that any sysop on the target wiki could then make guesses which pages exist on the private wiki and try to import them.
Comment 7 This, that and the other (TTO) 2014-02-12 01:57:19 UTC
(In reply to comment #5)
> (In reply to comment #1)
> > Why not legal.wikimedia.org?
> 
> To keep legal.wikimedia free incase it's wanted for something broader and
> more
> open then a confidential wiki.

How about legalteam.wikimedia.org? Using the name legalwiki.wikimedia.org could be confusing, as wiki internal names are by convention formed by taking the subdomain and adding "wiki".
Comment 8 Alex Monk 2014-02-12 02:01:52 UTC
I also disagree with 'legalwiki.wikimedia.org', especially if you see the potential of using legal.wikimedia.org in the future (which would probably be a wiki too, the difference between the two then actually being access controls - and obviously content).
Comment 9 James Alexander 2014-02-12 02:05:04 UTC
> How about legalteam.wikimedia.org? Using the name legalwiki.wikimedia.org
> could
> be confusing, as wiki internal names are by convention formed by taking the
> subdomain and adding "wiki".

> I also disagree with 'legalwiki.wikimedia.org', especially if you see the
> potential of using legal.wikimedia.org in the future (which would probably
> be a
> wiki too, the difference between the two then actually being access controls
> -
> and obviously content).

I'm fine with legalteam if we prefer, I don't really care I just want it to make sense and get done :).
Comment 10 This, that and the other (TTO) 2014-02-12 02:15:22 UTC
I note that ombudsmenwiki assigns no rights to the autoconfirmed and confirmed groups (except OAuth and transcode rights). Is this required for legalteamwiki?
Comment 11 James Alexander 2014-02-12 02:25:22 UTC
(In reply to comment #10)
> I note that ombudsmenwiki assigns no rights to the autoconfirmed and
> confirmed
> groups (except OAuth and transcode rights). Is this required for
> legalteamwiki?

hmm, no, I just saw that... not entirely sure why that was done but it would be best to still allow the normal options on legalteamwiki. I don't anticipate semi protection being a thing on the wiki obviously but no reason to turn something off (especially upload) without reason.
Comment 12 Gerrit Notification Bot 2014-02-12 06:14:39 UTC
Change 112850 had a related patch set uploaded by TTO:
Initial setup for legalteamwiki

https://gerrit.wikimedia.org/r/112850
Comment 13 Gerrit Notification Bot 2014-02-25 15:55:28 UTC
Change 112716 merged by jenkins-bot:
Add support for new private legalteamwiki

https://gerrit.wikimedia.org/r/112716
Comment 14 Gerrit Notification Bot 2014-03-01 03:47:12 UTC
Change 116219 had a related patch set uploaded by Jalexander:
Apache config for legalteamwiki

https://gerrit.wikimedia.org/r/116219
Comment 15 Gerrit Notification Bot 2014-03-01 04:02:04 UTC
Change 116220 had a related patch set uploaded by Jalexander:
DNS setup for legalteamwiki

https://gerrit.wikimedia.org/r/116220
Comment 16 Gerrit Notification Bot 2014-03-06 14:17:45 UTC
Change 116220 merged by Mark Bergsma:
DNS setup for legalteamwiki

https://gerrit.wikimedia.org/r/116220
Comment 17 Gerrit Notification Bot 2014-03-06 14:27:37 UTC
Change 116219 merged by Mark Bergsma:
Apache config for legalteamwiki

https://gerrit.wikimedia.org/r/116219
Comment 18 Gerrit Notification Bot 2014-03-06 14:46:05 UTC
Change 112850 merged by jenkins-bot:
Initial setup for legalteamwiki

https://gerrit.wikimedia.org/r/112850
Comment 19 Gerrit Notification Bot 2014-03-06 15:27:48 UTC
Change 112717 merged by jenkins-bot:
Enable VisualEditor for legalteamwiki by default

https://gerrit.wikimedia.org/r/112717
Comment 20 Sam Reed (reedy) 2014-03-06 15:33:30 UTC
This is mostly done now...

Does $stdlogo work on other privte wikis? https://upload.wikimedia.org/wikipedia/legalteam/b/bc/Wiki.png 404s
Comment 21 Sam Reed (reedy) 2014-03-06 15:34:11 UTC
(In reply to Sam Reed (reedy) from comment #20)
> Does $stdlogo work on other privte wikis?
> https://upload.wikimedia.org/wikipedia/legalteam/b/bc/Wiki.png 404s

Because it won't have been uploaded yet... Duh.
Comment 22 James Alexander 2014-03-07 03:19:46 UTC
(In reply to Sam Reed (reedy) from comment #21)
> (In reply to Sam Reed (reedy) from comment #20)
> > Does $stdlogo work on other privte wikis?
> > https://upload.wikimedia.org/wikipedia/legalteam/b/bc/Wiki.png 404s
> 
> Because it won't have been uploaded yet... Duh.

Yup, but you are indeed correct, it doesn't work for private wikis because it puts it into a different (private) file url scheme which you have to be logged in to use. I'm uploading a config patch with the logo.
Comment 23 Gerrit Notification Bot 2014-03-07 03:24:44 UTC
Change 117377 had a related patch set uploaded by Jalexander:
Add logo for legalteamwiki

https://gerrit.wikimedia.org/r/117377
Comment 24 Gerrit Notification Bot 2014-03-11 13:55:57 UTC
Change 117377 merged by jenkins-bot:
Add logo for legalteamwiki

https://gerrit.wikimedia.org/r/117377
Comment 25 This, that and the other (TTO) 2014-03-12 07:00:38 UTC
All done here methinks! Enjoy your new wiki.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links