Last modified: 2014-02-04 14:35:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 60827 - Unnecessary newline added to lists and tables when invoked through a template
Unnecessary newline added to lists and tables when invoked through a template
Status: RESOLVED DUPLICATE of bug 12974
Product: MediaWiki extensions
Classification: Unclassified
Scribunto (Other open bugs)
master
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-04 14:14 UTC by Matt Russell
Modified: 2014-02-04 14:35 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot showing both cases in Special:ExpandTemplates (9.95 KB, image/png)
2014-02-04 14:14 UTC, Matt Russell
Details

Description Matt Russell 2014-02-04 14:14:27 UTC
Created attachment 14480 [details]
Screenshot showing both cases in Special:ExpandTemplates

Bug 529 added the "feature" of adding a newline to templates when they are not at the start of the line if they start with wikitext which has to be at the start of the line (tables, lists, etc.). When using a plain template or invoking a module directly, this works fine. However, when using a template which invokes a module, the newline is ALWAYS added, regardless of if it is necessary.
This often results in nasty <p>s coming along and ruining everything, like they always do. :(

This is easy to test: create a module and a template which starts with a list or table. When using the module through a template you'll always get an extra newline, unlike direct invocation or plain templates, which only add it when necessary.
Comment 1 Brad Jorsch 2014-02-04 14:35:24 UTC
This also occurs if you create Template:list2 with contents "{{list}}".

*** This bug has been marked as a duplicate of bug 12974 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links