Last modified: 2014-01-26 15:57:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 60444 - # [[User:{{subst:REVISIONUSER}}|]] converts to different result than # [[User:<username>|]] for user name starting with "**"
# [[User:{{subst:REVISIONUSER}}|]] converts to different result than # [[User...
Status: RESOLVED DUPLICATE of bug 12974
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-26 15:53 UTC by Rainer Rillke @commons.wikimedia
Modified: 2014-01-26 15:57 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rainer Rillke @commons.wikimedia 2014-01-26 15:53:39 UTC
Steps to reproduce:
-----------------------
* Log in as User:**Romina**
* On an editable page, add
# [[User:{{subst:REVISIONUSER}}|]]
  and save that page. Result (obviously wrong):
# [[User:
**Romina**|]]
-----------------------
-----------------------

Expected behaviour/ comparison:
-----------------------
* On an editable page, add
# [[User:**Romina**|]]
  and save that page. Result (correct):
# [[User:**Romina**|**Romina**]]
-----------------------
-----------------------

Where can the issue be reproduced?
- In production/WMF. Example: https://commons.wikimedia.org/w/index.php?title=Commons:Picture_of_the_Year/2013/R1/v/Dead_Sea_salt_formation_%28Aerial_view,_2007%29.jpg&diff=prev&oldid=114757454
- With MW 1.23alpha
Comment 1 Bartosz Dziewoński 2014-01-26 15:57:59 UTC
This is the same thing as bug 12974. Good luck getting this behavior changed.

*** This bug has been marked as a duplicate of bug 12974 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links