Last modified: 2013-12-27 22:01:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 58615 - Math creates FSFileBackend in deprecated parameters
Math creates FSFileBackend in deprecated parameters
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Math (Other open bugs)
unspecified
All All
: Low minor (vote)
: ---
Assigned To: Vishnu Nk
: easy
Depends on:
Blocks: code_quality
  Show dependency treegraph
 
Reported: 2013-12-18 01:36 UTC by Bawolff (Brian Wolff)
Modified: 2013-12-27 22:01 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bawolff (Brian Wolff) 2013-12-18 01:36:39 UTC
Deprecated: Use of FileBackend::__construct called without "wikiID". was
deprecated in MediaWiki 1.23. [Called from FileBackendStore::__construct in
/var/www/w/git/includes/filebackend/FileBackendStore.php at line 68] in
/var/www/w/git/includes/debug/Debug.php on line 301

Deprecated: Use of FileBackend::__construct called with non-object
"lockManager". was deprecated in MediaWiki 1.23. [Called from
FileBackendStore::__construct in
/var/www/w/git/includes/filebackend/FileBackendStore.php at line 68] in
/var/www/w/git/includes/debug/Debug.php on line 301

-----

Possibly a good gci bug. Needs to change getBackend(), so that the default
config doesn't create a new FSFileBackend object without specifying wikiID and
a lockManager. The appropriate values are probably just wfWikiId() and new
NullLockManager( array() ) respectively.
Comment 1 Vishnu Nk 2013-12-24 08:41:13 UTC
I was not able to clone the repository Math.git by git clone method.
It says 

Permission denied (publickey).
fatal: The remote end hung up unexpectedly

Is there any altrenative way to clone the repository ?
Comment 2 Bawolff (Brian Wolff) 2013-12-24 08:46:53 UTC
That can happen when cloning over ssh, and:
*You haven't added your ssh key to gerrit
*You didn't specify a username in the ssh url, and your git username is different from your local login name. If that happens try
 git clone ssh://PUTYOURUSERNAMEHERE@gerrit.wikimedia.org:29418/mediawiki/extensions/Math.git
*You don't have ssh key agent thingy set up properly (This is more likely to happen on windows where all sorts of weird hoops are required to make ssh work)
Comment 3 Andre Klapper 2013-12-24 12:29:14 UTC
Vishnu: Please discuss generic development issues (which are not specific to this bug report) in a more generic place, e.g. on IRC or the talk page of http://www.mediawiki.org/wiki/Gerrit/Tutorial . Thanks!
Comment 4 Vishnu Nk 2013-12-24 13:38:53 UTC
Andre Klapper: I already worked on this and with Bawolff's help i was able to edit the page.And i edited the file MathTexvc.php as per the instructions and changed the getbackend(). But the problem occured when i tried to push the branch into gerrit.
I was not able to run the command git review -s/-R/ anything because it says permission denied or could not connect to gerrit.I wish you could figure it out.
Comment 5 physikerwelt 2013-12-24 16:39:52 UTC
Vishnu: For me the IRC channel #mediawiki (http://www.mediawiki.org/wiki/MediaWiki_on_IRC)  was helpful to learn how to use git (for mediawiki development).
I think the extension math should move away from storing files. Math 2.0 does not need to access the filesystem at all. Unfortunately there is a review bottleneck for the Math extension.
So all comments on Math 2.0 (https://gerrit.wikimedia.org/r/#/c/85801/) are most welcome.
Comment 6 Vishnu Nk 2013-12-27 18:12:35 UTC
https://gerrit.wikimedia.org/r/#/c/104061/

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links