Last modified: 2014-06-09 06:18:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 54670 - Fatal error: Call to a member function setFragment() on a non-object in ThreadPermalinkView.php on line 168
Fatal error: Call to a member function setFragment() on a non-object in Thre...
Status: RESOLVED DUPLICATE of bug 59791
Product: MediaWiki extensions
Classification: Unclassified
LiquidThreads (Other open bugs)
master
All All
: High normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 17553 39480
  Show dependency treegraph
 
Reported: 2013-09-26 22:20 UTC by Sam Reed (reedy)
Modified: 2014-06-09 06:18 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2013-09-26 22:20:25 UTC
Fatal error:  Call to a member function setFragment() on a non-object in /usr/local/apache/common-local/php-1.22wmf19/extensions/LiquidThreads/pages/ThreadPermalinkView.php on line 168
Comment 1 Sam Reed (reedy) 2013-09-26 22:21:27 UTC
[26-Sep-2013 22:10:19] Fatal error: Call to a member function setFragment() on a non-object at /usr/local/apache/common-local/php-1.22wmf19/extensions/LiquidThreads/pages/ThreadPermalinkView.php on line 168
Server: mw1212
Method: GET
URL: http://www.mediawiki.org/wiki/Thread:Talk:MediaWiki_1.19/Broken_redirects_and_sidebar_display_after_upgrade_from_MW_1.12_to_MW_1.19/reply_(2)
Backtrace:
#0 /usr/local/apache/common-local/php-1.22wmf19/extensions/LiquidThreads/pages/ThreadPermalinkView.php(168): ThreadPermalinkView::getSubtitle()
#1 /usr/local/apache/common-local/php-1.22wmf19/extensions/LiquidThreads/pages/ThreadPermalinkView.php(231): ThreadPermalinkView->getSubtitle()
#2 /usr/local/apache/common-local/php-1.22wmf19/extensions/LiquidThreads/classes/Dispatch.php(100): ThreadPermalinkView->show()
#3 /usr/local/apache/common-local/php-1.22wmf19/extensions/LiquidThreads/classes/Dispatch.php(220): LqtDispatch::threadPermalinkMain(Object(OutputPage), Object(Article), Object(Title), Object(User), Object(WebRequest))
#4 [internal function]: LqtDispatch::tryPage(Object(OutputPage), Object(Article), Object(Title), Object(User), Object(WebRequest), Object(MediaWiki))
#5 /usr/local/apache/common-local/php-1.22wmf19/includes/Hooks.php(199): call_user_func_array('LqtDispatch::tr...', Array)
#6 /usr/local/apache/common-local/php-1.22wmf19/includes/GlobalFunctions.php(3898): Hooks::run('MediaWikiPerfor...', Array)
#7 /usr/local/apache/common-local/php-1.22wmf19/includes/Wiki.php(423): wfRunHooks('MediaWikiPerfor...', Array)
#8 /usr/local/apache/common-local/php-1.22wmf19/includes/Wiki.php(305): MediaWiki->performAction(Object(Article), Object(Title))
#9 /usr/local/apache/common-local/php-1.22wmf19/includes/Wiki.php(591): MediaWiki->performRequest()
#10 /usr/local/apache/common-local/php-1.22wmf19/includes/Wiki.php(460): MediaWiki->main()
#11 /usr/local/apache/common-local/php-1.22wmf19/index.php(55): MediaWiki->run()
#12 /usr/local/apache/common-local/w/index.php(3): require('/usr/local/apac...')
#13 {main}
Comment 2 Siebrand Mazeland 2013-11-21 16:13:17 UTC
This issue has been documented since 2009-02-18, or almost 5 years.

*** This bug has been marked as a duplicate of bug 17553 ***
Comment 3 Andre Klapper 2014-02-10 11:58:00 UTC
Bug 17553 is a tracking bug, hence reverting duplication.

Marking as dup of bug 59791 as that has some code analysis already.

*** This bug has been marked as a duplicate of bug 59791 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links