Last modified: 2013-10-29 07:39:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 53572 - VisualEditor: Unexpected editing behaviour for Malayalam Text
VisualEditor: Unexpected editing behaviour for Malayalam Text
Status: RESOLVED FIXED
Product: VisualEditor
Classification: Unclassified
Language (Other open bugs)
unspecified
PC Linux
: Normal major
: VE-deploy-2013-09-12
Assigned To: D Chan
:
Depends on:
Blocks: 56295
  Show dependency treegraph
 
Reported: 2013-08-30 01:07 UTC by vssun
Modified: 2013-10-29 07:39 UTC (History)
6 users (show)

See Also:
Web browser: Firefox
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Attachment 1 (26.05 KB, image/png)
2013-08-30 01:07 UTC, vssun
Details
Attachment 2 (37.75 KB, image/png)
2013-08-30 01:11 UTC, vssun
Details

Description vssun 2013-08-30 01:07:43 UTC
Created attachment 13197 [details]
Attachment 1 [details]

Visual Editor became quite unusable (possibly) after a recent update in Malayalam Wikipedia. There are several selection, editing and linking problems started to appear recently. Two such problems are described here.

See the example below

1. Copy the following text and paste it in a test page at Malayalam Wikipedia using conventional editor and save it. 
ഈ ദുരന്തം ഐറിഷ് രാജ്യാതിർത്തി

2. Edit the page using VE.

3. Change the third word "ഐറിഷ്" to "അയർലൻഡ്". To do that, select the word "ഐറിഷ്" by double clicking on it and type the word അയർലൻഡ്.

4. Now I want to create a wikilink for അയർലൻഡ്. For that, I used shift+ctrl+left arrow. Now, instead of selecting the entire word, A PORTION OF THE WORD WAS SELECTED. See the attachment 1 [details]. 

5. Select the entire word അയർലൻഡ് using double clicking on it

6. Press ctrl+k. Now instead of popping up a linking suggestion for the word അയർലൻഡ്, THE WORD DISAPPEARED AND LINKING SUGGESTION FOR A PART OF NEXT WORD POPS UP. See the attachment 2 [details]
Comment 1 vssun 2013-08-30 01:11:49 UTC
Created attachment 13198 [details]
Attachment 2 [details]
Comment 2 vssun 2013-08-30 01:26:21 UTC
Sorry for the incorrect attachment links on the above comments. Please correct it if somebody can.
Comment 3 James Forrester 2013-08-30 01:46:06 UTC
(In reply to comment #2)
> Sorry for the incorrect attachment links on the above comments. Please
> correct it if somebody can.

Sorry, links in comments can't be edited in Bugzilla. :-(
Comment 4 D Chan 2013-09-11 23:46:18 UTC
There's code to address this bug in the following patch, which is due to go live by mediawiki.org on 13 September 2013:

https://gerrit.wikimedia.org/r/#/c/82858/

Please let us know whether it fixes the bug!
Comment 5 James Forrester 2013-09-12 04:09:03 UTC
Marking this as "FIXED" on the expectation that it's fixed - please re-open if you find that it is still occurring.
Comment 6 vssun 2013-09-16 06:46:02 UTC
Still facing all the problems mentioned at comment 1
Comment 7 Bartosz Dziewoński 2013-09-16 06:56:15 UTC
vssun, on which wiki? The patch is only deployed at [[mw:|MediaWiki.org]] right now.
Comment 8 Andre Klapper 2013-09-16 09:04:54 UTC
(In reply to comment #6)
> Still facing all the problems mentioned at comment 1

Please always provide clear and exact steps to reproduce (e.g. URL testcase).
Resetting status as I assume that this is fixed on mediawiki.org.
Comment 9 vssun 2013-09-16 12:08:58 UTC
(In reply to comment #7)
> vssun, on which wiki? The patch is only deployed at [[mw:|MediaWiki.org]]
> right
> now.

Thank you. The bug is about Malayalam Wikipedia (already mentioned in description)

When will this be deployed in ml.wikipedia?
Comment 10 Bartosz Dziewoński 2013-09-16 12:41:51 UTC
(In reply to comment #9)
> When will this be deployed in ml.wikipedia?

Assuming that VE is deployed according to the roadmap for MediaWiki: [[mw:MediaWiki_1.22/Roadmap]], September 19. (Sorry, I should have mentioned that in my previous comment :) )

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links