Last modified: 2006-04-30 08:42:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T7338, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 5338 - Heading colons and red / blue links - selfreference detection
Heading colons and red / blue links - selfreference detection
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2006-03-24 01:53 UTC by lɛʁi לערי ריינהארט
Modified: 2006-04-30 08:42 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description lɛʁi לערי ריינהארט 2006-03-24 01:53:56 UTC

Sorry for this!

[[:::{{FULLPAGENAME}}]] is still "selfrefering". However that link is shown as red.

In general: (today) [[:::foo]] is always shown red.

best regards reinhardt [[user:gangleri]]
Comment 1 lɛʁi לערי ריינהארט 2006-04-25 21:10:56 UTC
changed the url to a mirror

generates a link
with a header
"Editing :::foo"
This is how it works. No complaints. No comments.
Comment 2 David Benbennick 2006-04-30 00:14:52 UTC
Another note, if you try to save in

you get an edit conflict.
Comment 3 lɛʁi לערי ריינהארט 2006-04-30 00:25:51 UTC
This link is not "stable":

Please go to
and make more previews (with an empty content or whatever)

The *title* gets "shorter" and "shorter" ... and ends up at .
Comment 4 lɛʁi לערי ריינהארט 2006-04-30 00:41:08 UTC
(In reply to comment #3)

I edited
and saved (without any preview).

The result was a title which does not
exist / is empty.

Please see
and a shorter

These links show pages where the tab "article" is wrong.

the "edit" links shows an empty page.
Comment 5 David Benbennick 2006-04-30 03:59:42 UTC
Now this is really weird.  After the above note, I tried the following edit link
(with 3 colons, instead of 2):

It worked, and I actually managed to create a page.  See

The page is listed as a redirect in

Things are very bolloxed.  Obviously the database is perfectly happy to store a
page starting with :, but the user interface gets deeply confused.
Comment 6 David Benbennick 2006-04-30 04:52:54 UTC
So I moved [[CueCat]] to [[:CueCat]], by using ::CueCat as the destination in
Special:Movepage.  It worked.  But the result was that the page was lost (at
least, it was hard to find), and the admin move revert link _didn't work_!  I
eventually managed to move the page back to CueCat, but it wasn't easy.

If I were Willy on Wheels, I'd be wetting the bed right now in glee.  Imagine
the havoc he could cause by exploiting this flaw.  Therefore, I'm pushing the
severity of this bug up to "major".
Comment 7 Brion Vibber 2006-04-30 05:09:16 UTC
Such titles rejected as of r13960.
Comment 8 lɛʁi לערי ריינהארט 2006-04-30 08:42:28 UTC
Thanks Brion!

Note You need to log in before you can comment on or make changes to this bug.