Last modified: 2013-07-08 14:04:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 50245 - Improve JavaScript performance for input tools
Improve JavaScript performance for input tools
Status: RESOLVED DUPLICATE of bug 49935
Product: MediaWiki extensions
Classification: Unclassified
UniversalLanguageSelector (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: performance
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 17:10 UTC by Liangent
Modified: 2013-07-08 14:04 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Liangent 2013-06-26 17:10:24 UTC
It's reported by some users that input tool initialization (when clicked on a textbox) freezes their browsers for a short while.
Comment 1 Amir E. Aharoni 2013-06-26 17:42:21 UTC
Can anybody please provide a more detailed instruction to reproduce this? OS, browser, CPU, RAM, steps to reproduce?
Comment 2 Liangent 2013-06-27 05:58:52 UTC
The original reporter[1] states on her user page that she uses IE, and there's no more info.

[1] https://zh.wikipedia.org/w/index.php?title=Wikipedia:%E4%BA%92%E5%8A%A9%E5%AE%A2%E6%A0%88/%E6%8A%80%E6%9C%AF&oldid=27042994#.E8.BE.93.E5.85.A5.E6.A1.86.E7.BB.8F.E5.B8.B8.E5.8D.A1.E6.AD.BB
Comment 3 wulaquark 2013-06-27 07:16:07 UTC
WIN8, Firefox 21.0, i5-3210M, 4G
When I was busy for something like Excel outside the browser, and then I turned back to the browser, clicked the textbox, WHOLE browser freezed few seconds. During this period, NOT just textbox freezing, the whole browser lost response.

Interestingly, this problem do not 100% appear. I guess it may be due to loading limited by network speed, or this input method program requested too many system resources.
Comment 4 Siebrand Mazeland 2013-07-01 09:12:09 UTC
This works for me. Please provide more specific profiling or something. Otherwise it will be very hard to get any progress on this issue.
Comment 5 Liangent 2013-07-04 09:33:59 UTC
Maybe more or less related to bug 49935 comment 16.

That bug is about freeze on page load, but "ULS is full of that kind of crappy code" per MatmaRex.
Comment 6 Siebrand Mazeland 2013-07-08 14:04:43 UTC
Duping per comment 5.

*** This bug has been marked as a duplicate of bug 49935 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links