Last modified: 2013-05-22 18:12:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 48046 - New edit section link left of heading due to stale parser cache interacting with $wgUseTidy
New edit section link left of heading due to stale parser cache interacting w...
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.22.0
All All
: Low trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
https://meta.wikimedia.org/wiki/User_...
:
Depends on:
Blocks: editlinks
  Show dependency treegraph
 
Reported: 2013-05-03 13:18 UTC by Nemo
Modified: 2013-05-22 18:12 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wrong side (111.42 KB, image/png)
2013-05-03 13:18 UTC, Nemo
Details

Description Nemo 2013-05-03 13:18:01 UTC
Created attachment 12253 [details]
Wrong side

For some reason, on some pages the new edit section link is near the header, but on the wrong side, see screenshot (same on Vector logged out).

Steps to reproduce: unknown. Perhaps an interaction with the template above and its language magic.
Comment 1 Bartosz Dziewoński 2013-05-03 13:24:05 UTC
I have specifically hacked in a fix for this :/

Also, it happened just on one heading on a page? That's mad.
Comment 2 Bartosz Dziewoński 2013-05-03 13:36:12 UTC
Seems to be caused by $wgUseTidy being teh suck. The <span style=...> is interspersed with the <h2> in resulting HTML, confusing the hacky regex I'm using to wrestle old cached parser renders into the shape required by new links.

I'm inclined to WONTFIX this. action=purge will fix the issue, and this should be a rare occurrence.
Comment 3 Nemo 2013-05-03 13:39:41 UTC
(In reply to comment #2)
> I'm inclined to WONTFIX this. action=purge will fix the issue, and this
> should
> be a rare occurrence.

Yes, makes sense to WONTFIX if it's just temporary. I expected to be slapped an INVALID for some evil hack used by Meta, so I'm happy. :)
Comment 4 Bartosz Dziewoński 2013-05-12 21:20:02 UTC
WONTFIX it is, then.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links