Last modified: 2014-11-08 14:25:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 47916 - Be more helpful when (un)watching via JavaScript fails due to invalid token
Be more helpful when (un)watching via JavaScript fails due to invalid token
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
JavaScript (Other open bugs)
1.22.0
All All
: Low enhancement (vote)
: 1.24.0 release
Assigned To: Derk-Jan Hartman
: easy, i18n
Depends on: 65157
Blocks: messages
  Show dependency treegraph
 
Reported: 2013-05-01 07:19 UTC by Michael M.
Modified: 2014-11-08 14:25 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Michael M. 2013-05-01 07:19:06 UTC
It just happened to me that unwatching a page failed, because the token changed for some reason. I just got an error message of the kind "something went wrong" which doesn't help normal users (I could look in the JS console to find out what went wrong). Even if this shouldn't happen too often, MW should be more helpful. Possible enhancements:

* Add some hint how to fix it to the error message: "Reload the page and try again."
* Unbind the AJAX watch things when an error occurs (the non-AJAX token will probably be invalid, too, so the user will need to confirm the action a second time).
* Use action=tokens to get a new token and re-try automatically.
Comment 1 Nemo 2013-11-19 12:35:52 UTC
Adding many blockers of bug 38638 to the list of "easy" bugs, to mark them as candidates for [[mw:Google Code-in]] tasks (gci2013). If you think this bug is not suitable, remove the keyword.
Comment 2 Nemo 2014-11-07 06:56:57 UTC
Steps to reproduce:
1) Copy the URL to (un)watch a page
2) Log out and log in again, or wait a certain number of hours/days
3) Visit the URL

However, it would be better if you just gave us the exact message you saw. ;-) There are several token errors messages, IIRC.
Comment 3 Bartosz Dziewoński 2014-11-08 14:25:37 UTC
This should no longer occur since bug 65157 was fixed, the watch star JavaScript now re-tries with a new token when the request fail, as per your suggestion #3.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links