Last modified: 2014-03-10 20:34:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 47363 - Raise $wgMaxImageArea and $wgMaxAnimatedGifArea to highest allowable limit
Raise $wgMaxImageArea and $wgMaxAnimatedGifArea to highest allowable limit
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
wmf-deployment
All All
: Unprioritized enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: shell
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-18 15:49 UTC by Dominic
Modified: 2014-03-10 20:34 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dominic 2013-04-18 15:49:10 UTC
Half a year ago, in Bug 41125, $wgMaxImageArea and $wgMaxAnimatedGifArea were raised to 25 MP, and there have been no adverse effects. We are likely only talking about a few thousand images remaining that are above that limit, but it continues to be a problem for special areas like complex animations and archival-quality scans, some of which are features images on projects. And this will only become more common with time. I think the raise from 12.5 to 25 was relatively conservative given modern technology. A normal quality archival scan from even 5 years ago was already commonly producing images of 40 MP or more depending on the size of the document (we just don't have many TIFFs in general, so it hasn't seemed like a common problem).

I am wondering if the fact that there are so few of them means we could still render nearly all of the ones on Commons without a problem. Could we just set the arbitrary limit to something very much higher, like 100 or 200, just so no one can do anything too malicious?
Comment 1 Gerrit Notification Bot 2013-04-18 19:56:13 UTC
Related URL: https://gerrit.wikimedia.org/r/59925 (Gerrit Change Id6cf5515c55433d1ee502a21e145467bc3222f8f)
Comment 2 MZMcBride 2013-04-19 02:25:44 UTC
(In reply to comment #1)
> Related URL: https://gerrit.wikimedia.org/r/59925 (Gerrit Change
> Id6cf5515c55433d1ee502a21e145467bc3222f8f)

This changeset bumped both limits to 50MP and was merged.
Comment 3 Marco 2013-05-02 12:17:29 UTC
I am not sure if the problem is related, but some large thumbnails do still not get rendered.

* 77px OK
https://upload.wikimedia.org/wikipedia/commons/thumb/b/bf/Mejeri1.gif/77px-Mejeri1.gif

* 707px Not OK
https://upload.wikimedia.org/wikipedia/commons/thumb/b/bf/Mejeri1.gif/707px-Mejeri1.gif
Comment 4 Andre Klapper 2013-05-02 13:54:38 UTC
(In reply to comment #3)
> I am not sure if the problem is related, but some large thumbnails do still
> not get rendered.

Marco: Might have to do with size.

https://upload.wikimedia.org/wikipedia/commons/thumb/b/bf/Mejeri1.gif/576px-Mejeri1.gif works for me, https://upload.wikimedia.org/wikipedia/commons/thumb/b/bf/Mejeri1.gif/577px-Mejeri1.gif and above does not anymore. Can you confirm?

Worth to file a separate ticket and make it block bug 41371, as bug 9497 is about PNGs and not GIFs. Could you do that?
Comment 5 Marco 2013-05-24 13:53:33 UTC
(In reply to comment #4)
> Worth to file a separate ticket and make it block bug 41371, as bug 9497 is
> about PNGs and not GIFs. Could you do that?

see bug 48003

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links