Last modified: 2014-06-19 11:05:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 45910 - JJB: document "current build parameters" to trigger-build builder
JJB: document "current build parameters" to trigger-build builder
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Continuous integration (Other open bugs)
unspecified
All All
: Low minor (vote)
: ---
Assigned To: Mark Holmquist
: upstream
Depends on:
Blocks: documentation
  Show dependency treegraph
 
Reported: 2013-03-08 19:28 UTC by Mark Holmquist
Modified: 2014-06-19 11:05 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mark Holmquist 2013-03-08 19:28:36 UTC
Parsoid's tests go like this:

1. testCommit is called
2. testCommit calls runTests with current build parameters and ZUUL_COMMIT=$ZUUL_COMMIT^1
3. testCommit calls runTests again with only the current build parameters
4. testCommit compares the two results and publishes a junit file with the relevant information

The problem is, "current build parameters" is more complicated in JJB than it is in Jenkins proper.

We should add that option to the upstream of JJB.
Comment 1 Mark Holmquist 2013-03-08 20:49:46 UTC
My bad, it exists, it's just not documented.
Comment 2 Antoine "hashar" Musso (WMF) 2013-03-08 22:46:08 UTC
Then it need to be documented and the doc sent upstream :-]
Comment 3 Antoine "hashar" Musso (WMF) 2013-06-25 18:45:05 UTC
This need to be fixed in JJB.
Comment 4 Greg Grossmeier 2014-05-22 16:10:43 UTC
Mark: Are you still working on this? Or should this be released back into the grand pool of available bugs?
Comment 5 Andre Klapper 2014-06-16 12:38:05 UTC
mtraceur: Are you still working on this? Or should the assignee be reset?
Comment 6 Antoine "hashar" Musso (WMF) 2014-06-19 11:05:08 UTC
Fixed up by Mark Fri Mar 8 14:05:52 2013 -0800

https://review.openstack.org/23963

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links