Last modified: 2013-07-25 07:07:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 45111 - For some sitelinks Wikidata shows "The specified article could not be found"
For some sitelinks Wikidata shows "The specified article could not be found"
Status: VERIFIED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WikidataRepo (Other open bugs)
unspecified
All All
: High normal with 1 vote (vote)
: ---
Assigned To: Wikidata bugs
:
: 45106 45754 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-17 19:23 UTC by reza1615
Modified: 2013-07-25 07:07 UTC (History)
13 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description reza1615 2013-02-17 19:23:04 UTC
in wikidata for some pages it doesn't accept fa.wiki pages and it show  "The specified article could not be found on the corresponding site," error
i.e:
https://www.wikidata.org/w/index.php?title=Wikidata%3AProject_chat&diff=6793229&oldid=6792973

or

i.e.:https://www.wikidata.org/w/index.php?title=Wikidata%3AProject_chat&diff=6810812&oldid=6810290
Comment 1 pouyan 2013-02-21 22:38:23 UTC
I think it is problem with ZWNJ. I have tested random words with and without it. and words without ZWNJ work fine.
Comment 2 jeblad 2013-02-22 10:41:09 UTC
Yes, we replace some chars rather harshly (zwnj is one of them) and should probably change this.
Comment 3 jeblad 2013-02-22 14:55:26 UTC
It seems like some of the reported pages really don't exist, but it could be something else that is going on. Copy-pasting from the actual pages seems to work in a patchset, but as my Persian is a bit rotten I don't know if I got the right pages.
Comment 4 pouyan 2013-02-22 15:49:39 UTC
Hi, You can use these which have article in persian Wiki and have ZWNJ.

کمپانی واین‌اشتاین have one zwnj between واین and اشتاین

https://fa.wikipedia.org/wiki/%DA%A9%D9%85%D9%BE%D8%A7%D9%86%DB%8C_%D9%88%D8%A7%DB%8C%D9%86%E2%80%8C%D8%A7%D8%B4%D8%AA%D8%A7%DB%8C%D9%86

لست.اف‌ام have one zwnj between اف and ام

https://fa.wikipedia.org/wiki/%D9%84%D8%B3%D8%AA.%D8%A7%D9%81%E2%80%8C%D8%A7%D9%85

thanks
Comment 5 pouyan 2013-02-22 15:51:33 UTC
and on Persian keyboard the button combination for zwnj is shift+space-bar on win8, linux and mac.
Comment 6 reza1615 2013-02-22 15:56:05 UTC
also for finding palace of ZWNJ you can use http://rishida.net/tools/conversion/
it shows ZWNJ as U+200C or ‌
Comment 7 jeblad 2013-02-22 17:01:52 UTC
https://gerrit.wikimedia.org/r/#/c/50365/
Comment 8 jeblad 2013-02-25 11:12:18 UTC
*** Bug 45106 has been marked as a duplicate of this bug. ***
Comment 9 Shervin Afshar 2013-02-25 22:02:38 UTC
I see this as fixed for the interwiki link fields:

https://www.wikidata.org/wiki/Q485 (see the entry for fa which has a ZWNJ in the title).

But for the rest of editable content (labels, descriptions, etc) on the page, the issue still exists. 

Test case:

* Add the text "ش‌س" (logical order: U+634, U+200C, U+633).
* Save
* Pass if not changed; fail if saved as "ش س" (logical order: U+634, U+0020, U+633).
Comment 10 reza1615 2013-02-27 11:11:01 UTC
it is more than ZWNJ ! i.e.
I could http://www.wikidata.org/w/index.php?title=Q1368919&diff=7983848&oldid=7983799

but I couldn't add فهرست قسمت‌های دکستر to http://www.wikidata.org/wiki/Q794445 and it shows this error! ''The external client site did not provide page information.''
Comment 12 jeblad 2013-03-01 11:08:19 UTC
https://gerrit.wikimedia.org/r/#/c/50365/
Comment 13 reza1615 2013-03-02 07:45:47 UTC
after last update (Status_updates/2013_03_01)  still this patch doesn't work properly!
i.e. adding
fa > فهرست پررفت‌وآمدترین فرودگاه‌های آمریکا
to Q5358278 is not possible also for label it converts ZWNJs to space

http://www.wikidata.org/w/index.php?title=Q5358278&diff=8578026&oldid=7753780
Comment 14 pouyan 2013-03-02 10:11:36 UTC
Reza is right, the interface add a " " instead of ZWNJ, which is false.
Comment 15 jeblad 2013-03-04 12:40:04 UTC
This is _merged_ into our master, it is _not_ in production.
Comment 16 jeblad 2013-03-05 23:50:58 UTC
*** Bug 45754 has been marked as a duplicate of this bug. ***
Comment 17 abraham.taherivand 2013-03-06 17:15:51 UTC
Verified in Wikidata demo sprint 34

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links