Last modified: 2013-02-15 22:26:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 44982 - Raise timeout for editing & purging pages on enwiki
Raise timeout for editing & purging pages on enwiki
Status: RESOLVED DUPLICATE of bug 19262
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
wmf-deployment
All All
: Unprioritized critical (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-14 04:14 UTC by Aude
Modified: 2013-02-15 22:26 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Aude 2013-02-14 04:14:06 UTC
I want to *emphasis* this bug has nothing to do with wikidata, as I confirmed the issue before we enabled wikidata on enwiki.

I've been having trouble consistently with editing [[en:New York City]] the past days that I've tried.  And it's been an issue before with other large articles.

It takes like 30-40 sections just to load a page or revision of that article.

I takes longer it seems when I edit, hit save, then it times out and never reloads.  My edits *do* get saved and I have to manually reload the page (as above, takes another 30-40 seconds) and I can see my change *did* save.

This is a horrible user experience for editing and does not make me want to actually edit and improve such Wikipedia pages.  For a current events-related article, I'm sure the user experience would be next to impossible with edit conflicts and more.

At minimum, if we could increase the timeouts so a save and reload actually works would be great.

Generally, I'm hoping Lua and other stuff can help improve the experience but otherwise can't think of a specific solution to the general issue of slowness.
Comment 1 Aude 2013-02-14 04:15:51 UTC
Just to add...

For Wikidata, we'll see what we can do to optimize when it comes to parsing a page, of course, and be mindful of this issue.

But it won't solve the problem as it was a previously existing problem.
Comment 2 MZMcBride 2013-02-14 04:23:29 UTC
I don't think there's any good solution to this besides waiting for Scribunto to be deployed to the English Wikipedia in March 2013.
Comment 3 MZMcBride 2013-02-14 04:30:37 UTC
(In reply to comment #2)
> I don't think there's any good solution to this besides waiting for Scribunto
> to be deployed to the English Wikipedia in March 2013.

Apparently this is tentatively scheduled for February 18, 2013, at least according to <http://wikitech.wikimedia.org/index.php?title=Deployments&oldid=56389>.

I think this bug is largely a duplicate of bug 19262.
Comment 4 Aude 2013-02-14 04:54:00 UTC
probably is a duplicate.

As an interim solution, I removed a big fat ugly template from [[:en:New York City]] and then was able to save the page within the timeout period.

Maybe it's just this one especially bad apple :) of a page that I'm editing.  Although note general slowness all around, especially on big pages with large revision history, lots of templates, etc.
Comment 5 Aude 2013-02-14 11:56:18 UTC

*** This bug has been marked as a duplicate of bug 19262 ***
Comment 6 Aude 2013-02-14 11:57:16 UTC
We shall see what happens once we have Lua for templates, and perhaps open new bugs if things don't improve sufficiently
Comment 7 James Alexander 2013-02-15 22:26:28 UTC
sorry for bumping a closed bug but seems more appropriate here then the dupp. If it's just the template issue then that's fine but it seems that you, Aude, and others ( http://en.wikipedia.org/wiki/Wikipedia:VPT#Constant_error_messages ) are saying this is much worse then usual? I just want to make sure this isn't something new and therefore not really about the issue in the other (long standing) bug. We may be treating the symptom with Scribunto but if it's a relatively new 'cause' we probably want to create a bug for that as well to get it beaten out.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links