Last modified: 2013-07-01 16:40:29 UTC
This message should be "permission error" rather than "permissions errors", and should be retitled accordingly, for the following reasons:
*Except for bizarre corner cases, it will only generate one error, so the plural "errors" is inappropriate.
*For similar reasons, the error would generally only involve one permission (e.g. sysop, oversight). I'm a little less fussy about this one – after all, the word "permissions" has a special meaning in computing – but the singular would be preferable, and is the more common usage according to a Google search for "permission error" and "permissions error". In English, we generally don't pluralise attributive nouns unless we have to.
Related URL: https://gerrit.wikimedia.org/r/59060 (Gerrit Change I91848f98e59bddb4c33bb6ca4d5d9a2ebeeafada)
Change 59060 merged by jenkins-bot:
Change "permissions errors" message to "permission error"