Last modified: 2013-04-17 03:07:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 44497 - Simplify and remove jargon from protection level
Simplify and remove jargon from protection level
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Page protection (Other open bugs)
1.21.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2013-01-30 07:06 UTC by Isarra
Modified: 2013-04-17 03:07 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Isarra 2013-01-30 07:06:34 UTC
When a page is protected or its protection level changed, it puts for the protection level in the log and history 'Edit=Block new and unregistered users', 'Move=Block all non-admin users', and the like. This wording is unclear - 'block' is an unnecessary jargon term, and the length of the protection description makes it harder to quickly scan and figure out what it's actually saying.

If it is going to be in the format of 'Type=Level', the level should be the exact level with any necessary explanation following, along the lines of 'Move=Admins only' or 'Edit:Confirmed only'. Though the latter is unclear as to what 'confirmed' means, the similar 'Move=New and unregistered users disallowed' takes longer to get to the point while still remaining similarly unclear as to what exactly constitutes a 'new' user.

And given that log entries are currently restricted to a single line, the protection level descriptions must remain in a distinctly structured and short form as otherwise it makes the line difficult to scan.
Comment 1 Nemo 2013-04-16 17:04:03 UTC
This bug is extremely confusing, I've no idea what it is about.
1) The names for the protection levels? That's bug 43272 (whose fix may have superseded your comment, as the wording changed).
2) The term autoconfirmed? That's bug 43302.
3) The way the length is displayed?
4) Some other factor?
5) A combination of the above?

And all this:
A) As shown on history or logs?
B) As shown to the sysop in action=protect?
C) As shown anywhere, e.g. in action=info (bug 43283)?
D) combination of the three?

I suggest closing INVALID and filing specific bugs for specific issues, or a comprehensible tracking bug.
Comment 2 Isarra 2013-04-16 17:26:30 UTC
Looks like this was fixed at some point. 

Nemo, the bug was exactly what I described, and if you find that confusing I'm afraid there's not a whole lot I or anyone could do about that.

Though any link that might have been included with the bug originally wouldn't work now, it appears the log entries from the time still have some aspects of the change: http://en.wikipedia.org/w/index.php?title=Special%3ALog&type=protect&user=&page=&year=&month=1&tagfilter=
Comment 3 Nemo 2013-04-16 18:13:06 UTC
(In reply to comment #2)
> Looks like this was fixed at some point.

Nice! It's bug 43272 then.

*** This bug has been marked as a duplicate of bug 43272 ***
Comment 4 Isarra 2013-04-16 19:18:51 UTC
...no, it really isn't bug 43272. It's more like the opposite.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links