Last modified: 2013-04-29 19:10:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 44410 - Add pagination when displaying deleted revisions on Special:Undelete
Add pagination when displaying deleted revisions on Special:Undelete
Status: RESOLVED DUPLICATE of bug 7996
Product: MediaWiki
Classification: Unclassified
Page deletion (Other open bugs)
1.21.x
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 17:59 UTC by Jesús Martínez Novo (Ciencia Al Poder)
Modified: 2013-04-29 19:10 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jesús Martínez Novo (Ciencia Al Poder) 2013-01-27 17:59:33 UTC
When restoring a deleted page, it presents a form to put a reason for the undeletion, and below there's a list of *ALL* revisions that were deleted, with checkboxes to select each of them, without any pagination.

This presents problems with pages with lots (thousands) of deleted revisions. For example, deleting for merging histories, "accidentaly" delete a page, hide a specific revision, etc:

* If you attempt to load the Special:Undelete for that page, you may get a timeout an OOM or your browser crash/eat all your memory.

* If it even loads and you want to select lots of individual revisions to restore, you may hit the max_input_vars limit [1] (see bug 18687) and the selection won't be applied.

Pagination should be like page history.

Of course, pagination would be tricky for doing partial restoring, since on pagination you will lost the previous marked checkboxes. But at least the undelete page would load on pages with huge number of deleted revisions, and one could select revisions to restore in smaller batches.

----

[1] http://www.php.net/manual/info.configuration.php#ini.max-input-vars
Comment 1 MZMcBride 2013-04-29 03:51:01 UTC
Dupe of bug 7996?
Comment 2 Jesús Martínez Novo (Ciencia Al Poder) 2013-04-29 19:10:18 UTC
(In reply to comment #1)
> Dupe of bug 7996?

Indeed. I don't know how the search missed it

*** This bug has been marked as a duplicate of bug 7996 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links