Last modified: 2014-04-07 16:59:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 43528 - Non-friendly error message if user supplies wrong database password during install
Non-friendly error message if user supplies wrong database password during in...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.20.x
All All
: Normal normal (vote)
: ---
Assigned To: Tony Thomas
https://www.mediawiki.org/wiki/Thread...
: easy, i18n
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2012-12-31 01:01 UTC by Bawolff (Brian Wolff)
Modified: 2014-04-07 16:59 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bawolff (Brian Wolff) 2012-12-31 01:01:29 UTC
From support desk: https://www.mediawiki.org/wiki/Thread:Project:Support_desk/Error_when_trying_to_install_MediaWiki_1.20.2

It would appear supplying the wrong password to installer gives a rather ugly error message and plenty of headers already sent warnings. (Note I haven't tried this myself, I'm going solely on the reported error - and the fact its an access denied error. Its possible the situation may be more complicated then a simple wrong db pass.)

The error the user received is:

Warning: Cannot modify header information - headers already sent in C:\xampp\htdocs\wiki\includes\Exception.php on line 269

Warning: Cannot modify header information - headers already sent in C:\xampp\htdocs\wiki\includes\Exception.php on line 270

Warning: Cannot modify header information - headers already sent in C:\xampp\htdocs\wiki\includes\Exception.php on line 229 A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was: CREATE DATABASE `my_wiki` from within function "MysqlInstaller::setupDatabase". Database returned error "1044: Access denied for user @'localhost' to database 'my_wiki' (localhost)". Backtrace:

   1. 0 C:\xampp\htdocs\wiki\includes\db\Database.php(916): DatabaseBase->reportQueryError('Access denied f...', 1044, 'CREATE DATABASE...', 'MysqlInstaller:...', false)
   2. 1 C:\xampp\htdocs\wiki\includes\installer\MysqlInstaller.php(469): DatabaseBase->query('CREATE DATABASE...', 'MysqlInstaller:...')
   3. 2 [internal function]: MysqlInstaller->setupDatabase(Object(MysqlInstaller))
   4. 3 C:\xampp\htdocs\wiki\includes\installer\Installer.php(1454): call_user_func(Array, Object(MysqlInstaller))
   5. 4 C:\xampp\htdocs\wiki\includes\installer\WebInstallerPage.php(1161): Installer->performInstallation(Array, Array)
   6. 5 C:\xampp\htdocs\wiki\includes\installer\WebInstaller.php(269): WebInstaller_Install->execute()
   7. 6 C:\xampp\htdocs\wiki\mw-config\index.php(50): WebInstaller->execute(Array)
   8. 7 C:\xampp\htdocs\wiki\mw-config\index.php(18): wfInstallerMain()
   9. 8 {main}
Comment 1 Luis Felipe Schenone 2013-01-16 21:59:21 UTC
Could not reproduce the bug. However, while attempting to do so, I found that if the username is left out, then the error message, instead of saying something like "Username missing.", says "MySQL 5.0.2 or later is required, you have . "
Comment 2 Nemo 2013-11-19 12:36:19 UTC
Adding many blockers of bug 38638 to the list of "easy" bugs, to mark them as candidates for [[mw:Google Code-in]] tasks (gci2013). If you think this bug is not suitable, remove the keyword.
Comment 3 Gerrit Notification Bot 2014-03-14 19:04:24 UTC
Change 118742 had a related patch set uploaded by Pubudu538:
Error Msg for missing db username when installing

https://gerrit.wikimedia.org/r/118742
Comment 4 Gerrit Notification Bot 2014-03-15 07:12:11 UTC
Change 118798 had a related patch set uploaded by Pubudu538:
Error Msg for missing db username when installing

https://gerrit.wikimedia.org/r/118798
Comment 5 Gerrit Notification Bot 2014-03-16 06:19:20 UTC
Change 118742 abandoned by Pubudu538:
Error Msg for missing db username when installing

Reason:
Replaced this patch with another.

https://gerrit.wikimedia.org/r/118742
Comment 6 Gerrit Notification Bot 2014-03-26 04:15:13 UTC
Change 118798 had a related patch set uploaded by 01tonythomas:
Error Msg for missing db username & password  when installing

https://gerrit.wikimedia.org/r/118798
Comment 7 Gerrit Notification Bot 2014-04-07 16:59:04 UTC
Change 118798 merged by jenkins-bot:
Error Msg for missing db username & password  when installing

https://gerrit.wikimedia.org/r/118798

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links