Last modified: 2014-06-17 17:02:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 43227 - Navigation/Toolbox side panel is not collapsible/expandable when being logged out
Navigation/Toolbox side panel is not collapsible/expandable when being logged...
Status: RESOLVED FIXED
Product: MediaWiki skins
Classification: Unclassified
Vector (Other open bugs)
unspecified
All All
: High normal
: ---
Assigned To: Bartosz Dziewoński
http://terms.gbif.org/wiki/Main_Page
: code-update-regression, javascript
Depends on:
Blocks: 42452
  Show dependency treegraph
 
Reported: 2012-12-18 09:46 UTC by Andreas Plank
Modified: 2014-06-17 17:02 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Andreas Plank 2012-12-18 09:46:46 UTC
Hi

we upgraded from MW 1.18.1 to MW 1.20.2 and are using the (standard) vector skin but the side panel of navigation/toolbox is not collapsible. I checked it with browsers on a Linux machine: FireFox 17.0, Opera 12.11, Google Chrome Version 23.0.1271.97 
* they do not collapse the left side bar div#mw-panel element
* they do not show any errors in JavaScript debuggers like FireBug, Opera Dragonfly or the tool in Google chrome

At this time (18.12.2012 10:45) you can check it on our Terms Wiki http://terms.gbif.org/wiki/Main_Page (see also http://terms.gbif.org/wiki/Special:Version)

Is this phenomena known? (I found no related filed bugs)

Can this be solved? Thank you.

Andreas
Comment 1 Andre Klapper 2012-12-18 10:44:59 UTC
Hmm, Extension:Vector is installed in your wiki.
The only potentially relevant items that I can find in https://gerrit.wikimedia.org/r/gitweb?p=mediawiki/extensions/Vector.git;a=shortlog is bug 42354.
Comment 2 Gregor Hagedorn 2012-12-18 11:15:34 UTC
First: Confirmation that the problem occurs under Windows Chrome/FF as well.

Second: our copy of the Vector extension is from git-Head, so the bugfix
https://gerrit.wikimedia.org/r/#/q/status:merged+project:mediawiki/extensions/Vector,n,z should be included.

Third: we just discussed this and will try to disable selected extensions (the set of extensions worked ok under 1.18.x, but there may be some possible interference with changes in 1.20).
Comment 3 Andre Klapper 2012-12-18 11:25:05 UTC
Might be related: Similar problem described at https://de.wikipedia.org/wiki/Wikipedia:FZW#Sidebar_f.C3.BCr_unangemeldete_Benutzer_defekt.3F for users that are not logged-in.
Comment 4 Andre Klapper 2012-12-18 16:10:43 UTC
Looks like a regression from bug 42452 comment 37
Comment 5 Gregor Hagedorn 2012-12-19 08:08:23 UTC
The actual headings in the sidebar menu of version 1.20.2 are h5, ext.vector.collapsibleNav.css supports both h3 and h5 to be backwards compatible, but on cursory review it seems to me that ext.vector.collapsibleNav.js supports only h3, see e.g. or current version of HEAD (WMF may be different). https://gerrit.wikimedia.org/r/#/c/34702/2/modules/ext.vector.collapsibleNav.js

To me this seems to be a valid bug and no strange interaction with other extensions.
Comment 7 Bartosz Dziewoński 2012-12-23 13:08:17 UTC
I submitted I0a05ed39 to clean it up.
Comment 8 Andreas Plank 2013-01-04 08:30:26 UTC
Good! I0a05ed39 is submitted to master but how can it be included into the mediawiki version 1.20.2?
Comment 9 Andre Klapper 2013-01-04 11:07:19 UTC
Hi Andreas,

(In reply to comment #8)
> Good! I0a05ed39 is submitted to master

It says "Status: Review in Progress" - it's not merged yet.

> but how can it be included into the mediawiki version 1.20.2?

Are you asking how to apply the patch manually to your installation, or do you ask for a time machine to go back & put this in before 1.20.2 was released? :)
Comment 10 Andreas Plank 2013-01-04 11:28:09 UTC
Dear André

> Are you asking how to apply the patch manually to your installation, or do you
> ask for a time machine to go back & put this in before 1.20.2 was released? :)
time machine would be nice ;-)

I'm uncertain how it will be merged or be managed: MW 1.20.2 with vector extension has this bug and if it will be corrected, will there be an update/bug-fix release to MW 1.20.2 or do I have to use another MW 1.20.X or MW 1.2X version? On our Wiki we use presently MW core 1.20.2.

I guess I'll have to wait.

Andreas
Comment 11 Bartosz Dziewoński 2013-01-04 13:37:14 UTC
This patch is for the Vector extension anyway, not for MediaWiki core. So you would have to update Vector.

You can get the patch for this change using the command provided in the "Download -> patch" section on gerrit. Then you can apply it in the usual way.
Comment 12 Gregor Hagedorn 2013-01-04 22:41:49 UTC
I have manually applied the code and can confirm that it will be working. 

Please do a code review however and accept it in master. At the moment anyone trying to install mediawiki 1.20.2 will run against a wall here (yes, Vector is formally an extension, but there will be hardly a mediawiki installation that uses the vector skin (= new installation default), but does not use the standard functionality that only the extension provides).
Comment 13 Mark Holmquist 2013-01-05 00:33:55 UTC
Merged, thanks to all who helped out.
Comment 14 Bartosz Dziewoński 2013-01-05 18:07:46 UTC
(Making a release with the fixed version etc will probably be handled at bug 42452.)
Comment 15 Krinkle 2013-01-07 20:02:16 UTC
(In reply to comment #12)
> Please do a code review however and accept it in master. At the moment anyone
> trying to install mediawiki 1.20.2 will run against a wall here (yes, Vector
> is
> formally an extension, but there will be hardly a mediawiki installation that
> uses the vector skin (= new installation default), but does not use the
> standard functionality that only the extension provides).


This accessibility fix (h5 -> h3) was merged in master with I9a2ebd50.
This caused a bug in extensions/Vector which was fixed in these:
* I0a05ed39
* I7a20e853
* Id4a2058f
* I64794145

Neither are part of 1.20, so there is nothing to backport.
Comment 16 Bartosz Dziewoński 2013-01-07 20:06:06 UTC
My mistake; I misread the comments here.

The bug only manifested on a combination of MW core 1.20.2 or older with the Vector extension versions I64794145, Id4a2058f, I7a20e853 (the three linked by Krinkle).

Both current git master of Vector and a version older than I0a05ed39 (such as the one bundled with 1.20.2 release) work okay.
Comment 17 Gregor Hagedorn 2013-01-07 20:35:36 UTC
Yes, everything is ok now. When I wrote "Please do a code review however and accept it in master" I did not mean core, but vector; at the time of writing the fix by Bartosz (thanks Bartosz!) was not included when checking out extension/Vector HEAD.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links