Last modified: 2012-12-08 17:00:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 42662 - SpecialBlockList throwing exception on 1.21wmf5
SpecialBlockList throwing exception on 1.21wmf5
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CentralAuth (Other open bugs)
master
All All
: Immediate critical (vote)
: MW 1.21 version
Assigned To: Tim Starling
: code-update-regression
: 42664 (view as bug list)
Depends on:
Blocks: code_quality
  Show dependency treegraph
 
Reported: 2012-12-03 22:29 UTC by Sam Reed (reedy)
Modified: 2012-12-08 17:00 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2012-12-03 22:29:02 UTC
http://www.wikidata.org/wiki/Special:BlockList

2012-12-03 22:23:50 mw30 wikidatawiki: [33d74415] /wiki/Special:BlockList   Exception from line 116 of /usr/local/apache/common-local/php-1.21wmf5/extensions/CentralAuth/CentralAuthUser.php: No row object provided.
#0 /usr/local/apache/common-local/php-1.21wmf5/extensions/CentralAuth/CentralAuthUserArray.php(59): CentralAuthUser::newFromRow(false)
#1 /usr/local/apache/common-local/php-1.21wmf5/includes/UserArray.php(78): CentralAuthUserArrayFromResult->setCurrent(Object(stdClass))
#2 /usr/local/apache/common-local/php-1.21wmf5/extensions/CentralAuth/CentralAuthUserArray.php(21): UserArrayFromResult->__construct(Object(ResultWrapper))
#3 /usr/local/apache/common-local/php-1.21wmf5/extensions/CentralAuth/CentralAuthUserArray.php(10): CentralAuthUserArrayFromResult->__construct(Object(ResultWrapper))
#4 /usr/local/apache/common-local/php-1.21wmf5/extensions/CentralAuth/CentralAuthHooks.php(400): CentralAuthUserArray::newFromResult(Object(ResultWrapper))
#5 [internal function]: CentralAuthHooks::onUserArrayFromResult(NULL, Object(ResultWrapper))
#6 /usr/local/apache/common-local/php-1.21wmf5/includes/Hooks.php(253): call_user_func_array('CentralAuthHook...', Array)
#7 /usr/local/apache/common-local/php-1.21wmf5/includes/GlobalFunctions.php(3832): Hooks::run('UserArrayFromRe...', Array)
#8 /usr/local/apache/common-local/php-1.21wmf5/includes/UserArray.php(30): wfRunHooks('UserArrayFromRe...', Array)
#9 /usr/local/apache/common-local/php-1.21wmf5/includes/UserArray.php(52): UserArray::newFromResult(Object(ResultWrapper))
#10 /usr/local/apache/common-local/php-1.21wmf5/includes/specials/SpecialBlockList.php(439): UserArray::newFromIDs(Array)
#11 /usr/local/apache/common-local/php-1.21wmf5/includes/Pager.php(218): BlockListPager->preprocessResults(Object(ResultWrapper))
#12 /usr/local/apache/common-local/php-1.21wmf5/includes/Pager.php(529): IndexPager->doQuery()
#13 /usr/local/apache/common-local/php-1.21wmf5/includes/specials/SpecialBlockList.php(179): IndexPager->getNumRows()
#14 /usr/local/apache/common-local/php-1.21wmf5/includes/specials/SpecialBlockList.php(105): SpecialBlockList->showList()
#15 /usr/local/apache/common-local/php-1.21wmf5/includes/SpecialPage.php(612): SpecialBlockList->execute(NULL)
#16 /usr/local/apache/common-local/php-1.21wmf5/includes/SpecialPageFactory.php(497): SpecialPage->run(NULL)
#17 /usr/local/apache/common-local/php-1.21wmf5/includes/Wiki.php(291): SpecialPageFactory::executePath(Object(Title), Object(RequestContext))
#18 /usr/local/apache/common-local/php-1.21wmf5/includes/Wiki.php(555): MediaWiki->performRequest()
#19 /usr/local/apache/common-local/php-1.21wmf5/includes/Wiki.php(448): MediaWiki->main()
#20 /usr/local/apache/common-local/php-1.21wmf5/index.php(59): MediaWiki->run()
#21 /usr/local/apache/common-local/live-1.5/index.php(3): require('/usr/local/apac...')
#22 {main}
Comment 1 Sam Reed (reedy) 2012-12-03 23:41:03 UTC
*** Bug 42664 has been marked as a duplicate of this bug. ***
Comment 2 Tim Starling 2012-12-04 02:56:44 UTC
 23:57 logmsgbot: aaron synchronized php-1.21wmf5/extensions/CentralAuth/CentralAuthUser.php 'revert live hacks, exception already dumped in bugzilla' 

Would have been fixed at that point. The notice would be fixed by merging https://gerrit.wikimedia.org/r/#/c/36683/ but it appears to be harmless to leave it in for now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links