Last modified: 2013-04-02 17:11:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 42081 - Issues in legacy skins (tracking)
Issues in legacy skins (tracking)
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.21.x
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on: 7736 17693 20533 37879 37880 45944
Blocks: tracking 27292
  Show dependency treegraph
 
Reported: 2012-11-13 20:08 UTC by Bartosz Dziewoński
Modified: 2013-04-02 17:11 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bartosz Dziewoński 2012-11-13 20:08:50 UTC
Issues in legacy skins that could be easily fixed by killing them off.

See also changeset Ia6d73c2d, "Completely remove support for ancient skins".
Comment 1 Bartosz Dziewoński 2012-11-13 20:17:24 UTC
And by "legacy skins", I mean Nostalgia and Standard, the only two still using SkinLegacy and LegacyTemplate.
Comment 2 Marcin Cieślak 2012-11-13 20:20:14 UTC
Please be more specific, using "sucks" is not helpful. Just using a particular class as template is not a valid reason imho.
Comment 3 Bartosz Dziewoński 2012-11-13 20:22:31 UTC
This bug tracks all the issues in legacy skins. Or at least the ones I was able to find and pinpoint the problem - the four bugs currently here are caused by the lack of usage of standard navigation menus.
Comment 4 Bartosz Dziewoński 2012-11-13 20:23:32 UTC
Of course, it doesn't imply removing them; if anyone cares, they can go and fix them :)
Comment 5 James Forrester 2012-11-13 20:55:44 UTC
Leaving this where is is, but it's mostly a used-by-Wikimedia bug rather than a MediaWiki one.
Comment 6 Marcin Cieślak 2012-11-13 22:00:33 UTC
Well we have bug 27292 which does not seem to be overloaded with too many issues. All issues pointed by you are derivative of bug 37880, which is a single hook issue.
Comment 7 Bartosz Dziewoński 2013-04-02 17:01:34 UTC
This is invalid now that the legacy skins have been removed (Ia6d73c2d).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links