Last modified: 2013-04-22 16:14:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T43615, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 41615 - File history missing during Deletion/Restore
File history missing during Deletion/Restore
Product: MediaWiki
Classification: Unclassified
ContentHandler (Other open bugs)
All All
: Highest critical (vote)
: 1.21.0 release
Assigned To: Daniel Kinzler
: 41606 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2012-11-01 02:05 UTC by Robert Myers
Modified: 2013-04-22 16:14 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---

Example and display of the bug in question (549.47 KB, image/png)
2012-11-01 02:05 UTC, Robert Myers

Description Robert Myers 2012-11-01 02:05:18 UTC
Created attachment 11278 [details]
Example and display of the bug in question

When a file is deleted but later restored, the history is missing from the file, even though the history was displayed prior to the undeletion/restore. Deleteing the file again and undeleting seems to make the issue worse with the history totally missing. 

It isn't isolated as it is happening to every file on Commons and seems to have been occuring for around a week.

See attachment for the example of the bug
Comment 1 Fastily 2012-11-01 04:25:39 UTC
No luck editing either.

See [] for editing, and [] for the result that occurs after clicking 'save page', with any text.
Comment 2 Derrick Coetzee 2012-11-01 04:37:23 UTC
I observed this issue at:

I deleted and restored the image, to complete a history merge, but found the resulting history was completely empty. I tried to delete and re-restore to fix it, but the missing revisions were not listed on the restore screen. I tried to resubmit my original restore request with a refresh, but received the following errors: 

Errors were encountered while undeleting the file:

    Unable to restore file archive ID 2060260 because it is not in the database. 

It may have already been undeleted.

    Unable to restore file archive ID 2060258 because it is not in the database. 

It may have already been undeleted.

    Unable to restore file archive ID 2060259 because it is not in the database. 

It may have already been undeleted.
Comment 3 Derrick Coetzee 2012-11-01 05:08:45 UTC
See related (same?) bug:
Comment 4 Oliver Keyes 2012-11-01 05:24:23 UTC
This needs to be *highest* priority. I'm going to stick out a plea on the internal engineering list and ask for any fix to be backported.
Comment 5 Rob Lanphier (RobLa) 2012-11-01 05:27:43 UTC
*** Bug 41606 has been marked as a duplicate of this bug. ***
Comment 6 Rob Lanphier (RobLa) 2012-11-01 05:29:39 UTC
Several people are working on this bug now.  Assigning to Aude for now, but Aaron is also on this.
Comment 7 Oliver Keyes 2012-11-01 05:31:08 UTC
Thanks, robla :)
Comment 8 Rob Lanphier 2012-11-01 05:40:58 UTC
Further note: this bug is in 1.21wmf3, which had been deployed to all non-Wikipedia sites earlier today.  Our first response to this bug was to roll it back on almost all wikis (except test2, and  Aude is working on a fix with Aaron's advice.
Comment 9 Aude 2012-11-01 06:05:11 UTC
Comment 10 Daniel Kinzler 2012-11-01 11:31:11 UTC
Patch I796fe54e that fixes bug 41617 seems to also fix this issue.
Comment 11 Rob Lanphier 2012-11-01 18:19:13 UTC
This is now deployed, and 1.21wmf3 is reenabled.
Comment 12 Rob Lanphier 2012-11-01 18:39:46 UTC
Our short-term fix for this problem was reverting this on commons (and most others) from 1.21wmf3 to 1.21wmf2.  We've now just deployed the fixed version of 1.21wmf3 everywhere it was previously deployed.  We should be able to clean up any instances where this caused problems, and we'll work out a plan for that shortly (see bug 41649)
Comment 13 Daniel Kinzler 2012-11-02 12:51:34 UTC
Sorry for causing a mess :/
Comment 15 Aaron Schulz 2012-11-06 19:50:26 UTC
Are those complains about this bug? They seem more like bug 41794.
Comment 16 Andre Klapper 2012-11-12 14:37:03 UTC
Daniel: Can this be closed as per merged patch (in comment 10)? 
If not, what exactly is left to fix this completely?
Comment 17 Daniel Kinzler 2012-11-12 17:03:38 UTC
I think it is fixed, but I can not confirm, because I do not have access to the server logs. I suggest to close it if there are no further reports.
Comment 18 Daniel Kinzler 2012-11-14 19:56:46 UTC
closing again, no further reports of this happening. please reopen if needed.

Note You need to log in before you can comment on or make changes to this bug.