Last modified: 2013-04-22 16:14:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39559 - Mediawiki:Mwe-upwiz-deeds-macro-prompt needs {{GENDER}}
Mediawiki:Mwe-upwiz-deeds-macro-prompt needs {{GENDER}}
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UploadWizard (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Amir E. Aharoni
: i18n
Depends on:
Blocks: gender
  Show dependency treegraph
 
Reported: 2012-08-22 12:21 UTC by Srikanth Logic
Modified: 2013-04-22 16:14 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Srikanth Logic 2012-08-22 12:21:51 UTC
Some languages(localizers) require this message to support {{GENDER}}. See also bug 39052
Comment 1 Mark Holmquist 2012-08-22 16:26:59 UTC
Note: This bug may *manifest* in UploadWizard, but it's not a bug in the UW code. It's a bug in the mw.Message code. The mw.Message class needs to support the {{GENDER}} keyword in all its various forms, else there will be i18n issues wherever an extension tries to use that keyword in JavaScript. UW can't be the first, and it certainly won't be the last.
Comment 2 Amir E. Aharoni 2012-10-26 19:58:04 UTC
It does work there, but a bit differently - instead of the name it gets a user object. See
https://www.mediawiki.org/wiki/GENDER#PLURAL_and_GENDER_support_in_JavaScript

Despite being in the Language Engineering team, it's the first time I actually used GENDER in JavaScript, so I may have done something wrong, too :)

Patch in https://gerrit.wikimedia.org/r/#/c/30273/ .

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links