Last modified: 2013-04-11 13:35:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 38250 - encoding problem after upgrading
encoding problem after upgrading
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.19
All All
: Unprioritized major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 29731 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 18:32 UTC by Paolo Benvenuto
Modified: 2013-04-11 13:35 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
page table from a early install (11.56 KB, text/html)
2012-07-08 18:32 UTC, Paolo Benvenuto
Details

Description Paolo Benvenuto 2012-07-08 18:32:53 UTC
Created attachment 10829 [details]
page table from a early install

I installed mediawiki when it was in its early stages (1.5? it was the beginning of 2006) on a windows server. It was then upgraded to 1.15, then it was transferred to a linux server, and upgraded to 1.16.

Now I upgraded to 1.19, but I'm accented letters in article names are presented with weird characters, tipically the characters you see when a utf8-encoded text is interpreted as a latin1 one or viceversa.

Looking for a solution, I found this thread:

http://www.mediawiki.org/wiki/Thread:Project:Support_desk/UTF8_Problem_with_update_from_1.16_to_1.17

but it didn't help me to solve the issue.

Apparently the problem comes from the fact that my db has conserved some early version characteristic. I'm attacching a page table structure, where you can see varchar field, while I'm intending that mediawiki supposes to have varbinary ones.

The update script should check this case and manage it.
Comment 1 Alex Monk 2012-07-08 18:37:51 UTC
We found this problem while updating from/to 1.17/1.18 versions (I can't remember the exact version numbers).
Comment 2 Paolo Benvenuto 2012-07-08 19:17:01 UTC
How did you solve it?
Comment 3 Paolo Benvenuto 2012-07-08 20:01:28 UTC
Looking for a workaround, I upgraded to 1.17.4, but I got the same issue.
Comment 4 Andre Klapper 2013-01-01 12:24:12 UTC
Paolo: Does bug 32207 comment 3 help?
Comment 5 Paolo Benvenuto 2013-01-01 16:35:13 UTC
Andre, I could realize that my db install still had latin1 encoding, I had to convert it to utf8, I don't remember precisely how, but I solved it.
Comment 6 Andre Klapper 2013-04-11 13:35:18 UTC
*** Bug 29731 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links