Last modified: 2012-08-11 21:21:34 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 37718 - Button says "cancel" instead of "OK"
Button says "cancel" instead of "OK"
Status: RESOLVED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
EducationProgram (Other open bugs)
unspecified
All All
: Unprioritized minor (vote)
: ---
Assigned To: Jeroen De Dauw
:
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2012-06-19 19:16 UTC by Rob Schnautz
Modified: 2012-08-11 21:21 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rob Schnautz 2012-06-19 19:16:30 UTC
When adding a user as an ambassador for a course, the success message displays with a button that says "Cancel". It should say "OK" (or something along that line), since the change has already committed and pressing the button wouldn't reverse it.
Comment 1 Dereckson 2012-06-19 22:24:59 UTC
Here the list of the messages containing the  "Cancel" string:

* ep-pager-cancel-button-org
* ep-pager-cancel-button-course
* ep-articletable-addreviwer-cancel
* ep-articletable-remreviwer-cancel
* ep-articletable-remstudent-cancel
* ep-articletable-remarticle-cancel
* coursepage-delete-cancel-button
* orgpage-delete-cancel-button
* orgpage-eprestore-cancel-button
* coursepage-eprestore-cancel-button
* orgpage-epundo-cancel-button
* coursepage-epundo-cancel-button
* coursepage-epundelete-cancel-button
* orgpage-epundelete-cancel-button
* ep-disenroll-cancel
* ep-instructor-cancel-button
* ep-instructor-add-cancel-button
* ep-online-cancel-button
* ep-online-add-cancel-button
* ep-campus-cancel-button
* ep-campus-add-cancel-button

So from a localisation point of view, it's okay.

__________________

The problem then becomes one of those:
* a cancel button is used instead an OK button
* the cancel operation don't remove the ambassador
Comment 2 Jeroen De Dauw 2012-08-09 16:35:53 UTC
I can't reproduce this. Initially the dialogue has an "Add ambassador" button and a "Cancel" one. After submitting, you get a success message and the buttons get replaced by a "Close" one.
Comment 3 Jeroen De Dauw 2012-08-11 21:21:34 UTC
I'm going to assume this has already been fixed. If I'm wrong, please reopen :)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links