Last modified: 2013-07-03 11:19:34 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 37127 - UW will not create a category but it tells so
UW will not create a category but it tells so
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UploadWizard (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Nemo
:
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2012-05-26 01:17 UTC by Saibo
Modified: 2013-07-03 11:19 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Saibo 2012-05-26 01:17:51 UTC
"Diese Kategorie wird erstellt werden." (probably "this category will be created" in Englisch)  is wrong in the Commons language. The category page will no be created - that is commonly referred to as "creation" of a category. 
I could not find out which MediaWiki message this text is to correct it in Translatewiki by using lang=qqx. Seems to be hard wired. 

The text should be somehting like that: "This category is not existing yet! If you are no beginner you can create it afterwards."
Comment 1 Mark Holmquist 2012-05-28 18:06:36 UTC
Saibo, we use lang=qqq for i18n documentation of messages. In any case, the message is called 'mwe-upwiz-category-will-be-added' and means to say that we will add the file to the category, but you're right, the actual category page doesn't get created. I suppose this only means "There is no page for this category, but we'll add this file to it anyway".

With that information, is there a better way we could intimate that idea to the user? Maybe something like "This category is new, be careful!"?
Comment 2 Raimond Spekking 2012-05-28 18:15:58 UTC
(In reply to comment #1)
> Saibo, we use lang=qqq for i18n documentation of messages. 

You are right but qqx is some kind of magic: https://commons.wikimedia.org/w/index.php?title=Special:UploadWizard&uselang=qqx

You see the message keys instead of the message itself. But this trick does not work for the whole UW process because of JavaScript.

Back to the bug itelf: I would consider rewording the message, to something like "This category does not exist, be careful".
Comment 3 Mark Holmquist 2012-05-28 18:38:41 UTC
All right, I've made a patch that changes the message: https://gerrit.wikimedia.org/r/9151

I'm not sure if that's the best way to do it, so if someone else has a problem with the wording, they'll certainly voice it in their review.
Comment 4 Saibo 2012-06-02 01:35:59 UTC
thanks - have corrected it at https://translatewiki.net/wiki/MediaWiki:Mwe-upwiz-category-will-be-added/de
Comment 5 Nemo 2012-07-25 07:47:55 UTC
Patch has been abandoned...
I've been very confused by this message myself.
Comment 6 Mark Holmquist 2012-08-14 16:52:21 UTC
I think this was obviated in the fix for bug 28850, please confirm so we can close this.
Comment 7 Nemo 2012-08-14 17:07:46 UTC
(In reply to comment #6)
> I think this was obviated in the fix for bug 28850, please confirm so we can
> close this.

I think that has been deployed well before my last comment, so the problem is still there. I don't think we need a warning to get people fix it, but "the category will be created" is diseducating users. 
Just change it to "This category doesn't exist". Or do we think that users would think of a category as a collection of category links rather than a page which shows such collection hence this wouldn't make sense to them?
Comment 8 Mark Holmquist 2012-08-14 17:13:05 UTC
Oh, wow. Testing. Yeah, that fix *introduced* the bug, sorry.

So it looks like the best way to fix this might be on TranslateWiki? The German message appears to have been fixed, so that's done.

But the gerrit patch got abandoned because a reviewer said he was working on a better category picker. However long that will take (Erik? Thoughts?) it should fix this problem.

(adding Erik so he can share thoughts on the new category picker)
Comment 9 Nemo 2012-08-14 17:19:49 UTC
(In reply to comment #8)
> So it looks like the best way to fix this might be on TranslateWiki? The German
> message appears to have been fixed, so that's done.

No. The source can't be changed on translatewiki.net and translations can't do different things than the source (like transforming a message into its opposite). 

> 
> But the gerrit patch got abandoned because a reviewer said he was working on a
> better category picker. However long that will take (Erik? Thoughts?) it should
> fix this problem.
> 
> (adding Erik so he can share thoughts on the new category picker)

Erik rightfully objected to the "scary warning" part of the proposal. I think the message can be made neutral right now, and replaced later if UW changes, e.g. if we have a category picker which makes it easy to select the correct category and we think that when it doesn't find one the user has done something wrong he should be warned about.
Comment 10 Nemo 2012-09-19 09:31:37 UTC
I've recently had this "warning" about creating categories even if categories existed, after entering their name myself. It might have been due to some trailing space, or maybe it's always shown when pasting the category name.
Comment 11 Nemo 2013-01-01 12:16:39 UTC
(In reply to comment #9)
> I think
> the message can be made neutral right now, and replaced later if UW changes,

Gerrit change #41832. I was really getting tired of this.

(In reply to comment #10)
> I've recently had this "warning" about creating categories even if categories
> existed, after entering their name myself. It might have been due to some
> trailing space, or maybe it's always shown when pasting the category name.

This is not addressed by the patch: does someone know what the problem was in that case?
Comment 12 Nemo 2013-01-02 12:06:57 UTC
Change merged, let's call this fixed. Saibo, other problems should be filed as different specific bugs to make them more likely to be fixed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links