Last modified: 2012-11-01 17:34:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 36276 - [Regression] MySkin should be a very basic blank start
[Regression] MySkin should be a very basic blank start
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.20.x
All All
: Normal blocker with 1 vote (vote)
: Future release
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 36664
  Show dependency treegraph
 
Reported: 2012-04-26 16:17 UTC by Jarry1250
Modified: 2012-11-01 17:34 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jarry1250 2012-04-26 16:17:34 UTC
MySkin is, as I understand it, an attempt at a blank slate. However, it does include MediaWiki:common.css (and skins/common/commonPrint.css and skins/common/shared.css)

There is a suggestion that "redlinks" (a.new), viewed on MySkin, used to render in red. That would suggest to me that users using that particular skin used to be given skins/common/commonElements.css, which defines the redness of redlinks.

I can't believe that changing the display of a skin being used by people was intentional-more likely an unintentional side effect of tidying up CSS dependencies.

Could someone confirm?
Comment 1 Krinkle 2012-04-26 18:26:32 UTC
(correcting bug meta data)
Comment 2 Krinkle 2012-04-26 18:27:33 UTC
If this is indeed a bug, I suspect it is easy to fix.

In the mean time, could you provide more details? Can you be more specific in what you would expect the styles to be vs. what they are?
Comment 3 Jarry1250 2012-04-26 19:02:34 UTC
(In reply to comment #2)
> In the mean time, could you provide more details? Can you be more specific in
> what you would expect the styles to be vs. what they are?

On the VPT thread, the regular MySkin user reported that redlinks used to be red, but now are not (post 1.20wmf1 deploy). I suspect other bits of styling have also gone (the other things in commonElements.css), but that those changes have not yet been noticed because they are less obvious that redlinks.
Comment 4 Derk-Jan Hartman 2012-04-27 12:24:57 UTC
Red links were forced by the preferences, but now no longer are. It seems new links are not currently defined in common and of course myskin does not have any styling for it itself, since it is purposefully 'unstyled'.

So adding a generic .new styling to common would solve it probably.
Comment 5 Mark A. Hershberger 2012-09-30 17:07:44 UTC
(In reply to comment #4)
> So adding a generic .new styling to common would solve it probably.

Such a simple fix ... Could probably be done in time for 1.20 tarball.
Comment 6 Mark Holmquist 2012-11-01 17:24:59 UTC
https://gerrit.wikimedia.org/r/31278 proposed and merged. Thanks, MatmaRex!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links