Last modified: 2014-01-07 10:30:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 35314 - Lohit-Kannada doesnt display English characters in Chrome
Lohit-Kannada doesnt display English characters in Chrome
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UniversalLanguageSelector (Other open bugs)
unspecified
PC Windows XP
: Low major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://code.google.com/p/chromium/iss...
: i18n, upstream
: 33700 (view as bug list)
Depends on:
Blocks: 40760 53015
  Show dependency treegraph
 
Reported: 2012-03-19 07:19 UTC by Srikanth Logic
Modified: 2014-01-07 10:30 UTC (History)
12 users (show)

See Also:
Web browser: Google Chrome
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Title's first English word is eaten up by chrome (144.89 KB, image/png)
2012-03-19 07:19 UTC, Srikanth Logic
Details
Single English word isnt shown at all (117.74 KB, image/png)
2012-03-19 07:21 UTC, Srikanth Logic
Details

Description Srikanth Logic 2012-03-19 07:19:16 UTC
Created attachment 10265 [details]
Title's first English word is eaten up by chrome

Lohit-Kannada doesnt show English characters fully on title in knwp.

http://kn.wikipedia.org/wiki/Wikipedia:Kannada_Support show only ವಿಕಿಪೀಡಿಯ:Kannada Support but when I select and copy it copies ವಿಕಿಪೀಡಿಯ:Kannada Support  as 

I am using Chrome 17.0.963.79 m on Win XP. I noticed the same on Ubuntu + Chrome as well.
Comment 1 Srikanth Logic 2012-03-19 07:21:23 UTC
Created attachment 10266 [details]
Single English word isnt shown at all

I did a random check on other Lohit fonts in Telugu,Sanskrit on Google Chrome, issue doesnt exist. Even on kn, Kedage works fine.
Comment 2 Srikanth Logic 2012-03-19 07:23:02 UTC
(In reply to comment #0)
> Created attachment 10265 [details]
> Title's first English word is eaten up by chrome
> 
> Lohit-Kannada doesnt show English characters fully on title in knwp.
> 
> http://kn.wikipedia.org/wiki/Wikipedia:Kannada_Support show only
> ವಿಕಿಪೀಡಿಯ:Kannada Support but when I select and copy it copies
> ವಿಕಿಪೀಡಿಯ:Kannada Support  as 

err. copy paste issue


> http://kn.wikipedia.org/wiki/Wikipedia:Kannada_Support show only
> ವಿಕಿಪೀಡಿಯ: but when I select, it shows ವಿಕಿಪೀಡಿಯ:Support and when I copy it copies
> ವಿಕಿಪೀಡಿಯ:Kannada Support.
Comment 3 Santhosh Thottingal 2012-03-19 10:21:31 UTC
* Tried it on Windows 7 SP1 + Chrome 17.0.963.79 m, I saw the fallbacks working properly and English is visible.
* Chromium 7.0.963.56 (Developer Build 121963 Linux) Debian wheezy/sid - could not reproduce
* Chromium and Chrome in Ubuntu 11.10, not reproducible
* Reproducible in Windows XP and Chrome

http://crossbrowsertesting.com/users/34057/screenshots/zbbc2c88a2b00bc6e676/public has screenshots.
Page used for testing: http://kn.wikipedia.org/w/index.php?title=%E0%B2%B5%E0%B2%BF%E0%B2%B6%E0%B3%87%E0%B2%B7:UserLogin

Font fallback is working, but failing when a single html text node has mixed languages in Windows XP+ Chrome case. If the text node has some other language, but not mixed, it is working. See the English links in the screenshot.

I will report the issue upstream(chrome).
Comment 4 Santhosh Thottingal 2012-03-19 10:46:05 UTC
Upstream bug http://code.google.com/p/chromium/issues/detail?id=118885
Comment 5 Siebrand Mazeland 2012-07-09 04:27:02 UTC
*** Bug 33700 has been marked as a duplicate of this bug. ***
Comment 6 Jayanta Nath 2012-10-11 07:14:10 UTC
Same issue we are facing in Bengali wikipedia with Lohit Bengali font and using Chrome 21 m on Win XP SP3.
Comment 7 Amir E. Aharoni 2013-06-13 21:48:24 UTC
Moving to ULS.
Comment 8 Santhosh Thottingal 2014-01-07 10:30:01 UTC
Not able to reproduce the issue in Chrome 30, Windows XP SP3. Screenshot http://app.crossbrowsertesting.com/public/id1b2af101bb8ef7/livetests/1298873/snapshots/z8790e92bbb0546a49b0

Upstream bug also not actionable since the issue is not present in recent version of chrome.

So closing.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links