Last modified: 2013-04-22 19:29:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 33193 - Review and deploy Score extension to Wikimedia wikis
Review and deploy Score extension to Wikimedia wikis
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Extension setup (Other open bugs)
unspecified
All All
: Normal enhancement with 3 votes (vote)
: ---
Assigned To: Sam Reed (reedy)
: shell
Depends on: 43388 46374
Blocks: 31235 Wikisource 189
  Show dependency treegraph
 
Reported: 2011-12-16 13:44 UTC by Sumana Harihareswara
Modified: 2013-04-22 19:29 UTC (History)
24 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sumana Harihareswara 2011-12-16 13:44:04 UTC
http://www.mediawiki.org/wiki/Extension:Score

Review and deploy GrafZahl's Score extension on the cluster.  References:

https://bugzilla.wikimedia.org/show_bug.cgi?id=189#c116

"After Nemo's recent mail [1] on wikisource-l, I created a rewrite of the
LilyPond extension at http://www.mediawiki.org/wiki/Extension:Score

Hopefully, this rewrite addresses comments 103 and 105 (sans the "optional"
stuff), and also Tim Starling's recent review [2].

[1] http://lists.wikimedia.org/pipermail/wikisource-l/2011-December/001053.html
[2] https://www.mediawiki.org/wiki/Special:Code/MediaWiki/98414#c27299 "
Comment 1 Mark A. Hershberger 2011-12-16 22:36:31 UTC
Commenting here to create comment links (hopefully):

Bug 189 comment 103 -- Uses lilypond, so I think this is addressed.
Bug 189 comment 105 -- ditto
Comment 2 Bawolff (Brian Wolff) 2011-12-17 04:23:11 UTC
I made some minor fix ups to the extension in r106499 (mostly fixes relating to which wfMsg function needed to be used, see the commit summary for full details) 

I wonder if the alt text should also be the title text in "Raw" mode.

I think this extension might need to be changed to work with the new file backend stuff. (I haven't actually read the new file backend code, so couldn't say for sure).

Anyhow, good work on getting this moving forward
Comment 3 Graf.Zahl 2011-12-20 12:52:28 UTC
(In reply to comment #2)
> I think this extension might need to be changed to work with the new file
> backend stuff. (I haven't actually read the new file backend code, so couldn't
> say for sure).

What precisely is the "new file backend stuff"? I found http://www.mediawiki.org/wiki/FileBackend, but this appears to be still in the planning stage?
Comment 4 Bawolff (Brian Wolff) 2011-12-20 21:45:48 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > I think this extension might need to be changed to work with the new file
> > backend stuff. (I haven't actually read the new file backend code, so couldn't
> > say for sure).
> 
> What precisely is the "new file backend stuff"? I found
> http://www.mediawiki.org/wiki/FileBackend, but this appears to be still in the
> planning stage?

Well its no longer in the planning stage as of yesterday (r106752). At this stage there's probably not to much docs for it, so I wouldn't be super concerned just yet.
Comment 5 Sam Reed (reedy) 2011-12-24 16:51:11 UTC
-shell

Not required until extension is fully reviewed and has been marked ok for deployment
Comment 6 Sumana Harihareswara 2012-04-04 14:20:01 UTC
GrafZahl, thanks for your work and sorry for the wait.  I see via https://www.mediawiki.org/w/index.php?title=Special:Code/MediaWiki&path=%2Ftrunk%2Fextensions%2FScore%2F that you have made a few more improvements since December.  Is your extension ready for a thorough review for deployment?  If so, please use https://www.mediawiki.org/wiki/Git/Conversion/Extensions_queue to request a move to Git.  It needs to be in Git before it can be deployed on WMF sites.  Thanks!
Comment 7 Tim Starling 2012-04-20 06:43:28 UTC
I've fixed up a few minor issues with it, and added it to the git migration queue. 

The main remaining problem with it is the high load it will put on the NFS server. The Math extension has a DB table which tracks created files, and that allows the stat() syscalls to be avoided in favour of slave DB requests. By contrast, this extension will do several stat() calls per score on every parse.

Storing the source text and options in the database would allow the images to be regenerated after a software update, a feature sorely missed in the Math extension. 

Generating the MIDI file unconditionally would allow for more effective caching of the LilyPond output, and would avoid the need to separately check whether the MIDI file exists on every cache hit.
Comment 8 Sumana Harihareswara 2012-04-24 00:39:46 UTC
GrafZahl, can you address this performance issue this week?  If not, Tim is interested in working on it at the end of the week (Friday in Australia).  Thanks.
Comment 9 Beau 2012-05-10 09:32:57 UTC
Is anyone working on this? If not, I can try to adddress issues raised by Tim.
Comment 10 Mark A. Hershberger 2012-05-11 02:05:49 UTC
(In reply to comment #9)
> Is anyone working on this? If not, I can try to adddress issues raised by Tim.

That would be awesome!  I haven't heard from upstream in a while, so if you can take this, we'll get it deployed that much sooner.
Comment 11 Beau 2012-05-14 08:31:38 UTC
I have submitted 4 changes for review:
- Gerrit change #7359
- Gerrit change #7378
- Gerrit change #7492
- Gerrit change #7581
Comment 12 Beau 2012-05-29 13:00:25 UTC
Still no review for the code I made.
Comment 13 Sumana Harihareswara 2012-06-15 19:51:34 UTC
GrafZahl, can I ask you to help review the new Score code via https://gerrit.wikimedia.org/r/#/q/status:open+project:mediawiki/extensions/Score,n,z ?
Comment 14 MZMcBride 2012-07-05 04:53:56 UTC
What's the status of this bug? Are Beau's changes still awaiting review?
Comment 15 Helder 2012-07-05 10:45:06 UTC
I think so. The changes on Sumana's link were not reviewed.
Comment 16 Sumana Harihareswara 2012-07-17 21:53:24 UTC
Adding Arthur Richards to cc since he's done some review for one of the outstanding Score changesets.  Arthur, I have taken the liberty of also requesting you to review the other outstanding patchsets for Score, in case you have time?

Markus, adding you to cc because of your Wikimania presentation https://wikimania2012.wikimedia.org/wiki/Submissions/We_want_scores! -- couldn't find Anja's email in the BZ user list, but maybe she'd like to be cc'd as well?
Comment 17 Arthur Richards 2012-07-17 22:50:30 UTC
Thanks Sumana. I'm happy to keep doing review, which will generally happen on Fridays although I sometimes find other times during the week to get some review done. I think this is a super cool extension and would definitely like to see it eventually out in the wild :)
Comment 18 Markus Glaser 2012-07-24 12:07:12 UTC
Thanks Sumana! I added Anja to cc. 

@Arthur, let me know if I can be of any help.
Comment 19 Jarry1250 2012-08-22 18:52:05 UTC
Any progress, a month on? It all sounds rather exciting.
Comment 20 Sumana Harihareswara 2012-08-22 20:40:18 UTC
We're awaiting fixes in response to code review by Tim Starling, Markus Glaser, and Arthur Richards.  https://gerrit.wikimedia.org/r/#/q/status:open+project:mediawiki/extensions/Score,n,z has the list of patchsets.  It's most likely that Szymon Świerkosz (Beau) or GrafZahl would be responding to that critique.  But anyone can.... :)
Comment 21 Mark A. Hershberger 2012-08-26 13:14:39 UTC
https://gerrit.wikimedia.org/r/#/q/project:mediawiki/extensions/Score,n,z

Looks like everything was merged?  Any ETA on deployment?  Any place where deployment can be discussed?
Comment 22 MZMcBride 2012-08-26 14:34:18 UTC
(In reply to comment #21)
> https://gerrit.wikimedia.org/r/#/q/project:mediawiki/extensions/Score,n,z
> 
> Looks like everything was merged?  Any ETA on deployment?  Any place where
> deployment can be discussed?

So it looks like Ifcad0daf was abandoned by Tim on August 24 because Swift was going to be used to resolve the issue instead. Is there a new changeset addressing the issue that Ifcad0daf sought to address?

If so, you may be ready for a final review and deployment. I believe the current schedule is at <http://wikitech.wikimedia.org/view/Software_deployments>. You need to find a shell "shepherd" (if you will) who will help you get this deployed.
Comment 23 Tim Starling 2012-08-26 23:09:21 UTC
It's not ready for deployment.
Comment 24 Jarry1250 2012-08-27 12:36:59 UTC
(In reply to comment #23)
> It's not ready for deployment.

Just for the reasons MZM mentioned, or are there other code review issues?
Comment 25 Sumana Harihareswara 2012-09-05 21:31:00 UTC
I've heard from the code author that he does not currently have time to work on Score.  So, if Tim and Arthur could specify what now needs fixing in Score to get it ready for deployment, that would be great; I could ask GrafZahl to fix those, or try to find another volunteer.  Thanks.
Comment 26 Sumana Harihareswara 2012-09-10 21:54:28 UTC
Tim's fixing up some issues in Score, working on it every Friday, and will be committing into Git when he has more progress.
Comment 27 Sumana Harihareswara 2012-09-10 21:55:48 UTC
Specifically, the issue is Swift support -- everything that writes to a filesystem has to be able to work with Swift, and so Tim's working on that.
Comment 28 Alex Monk 2012-09-30 16:57:43 UTC
I noticed that the Swift support has been pushed to Gerrit, so I guess it's waiting for review: Gerrit change #23644
Comment 29 Sumana Harihareswara 2012-10-11 01:04:31 UTC
Aaron reviewed the code today and requested a few improvements. Tim or Markus, which of you would like to improve the patchset to accord with Aaron's suggestions?
Comment 30 Sumana Harihareswara 2012-11-06 21:57:32 UTC
Markus, do you have time to work on this?
Comment 31 Markus Glaser 2012-11-07 15:13:34 UTC
Sumana, I guess so. Will give it a try next week.
Comment 32 Sumana Harihareswara 2012-11-16 21:50:43 UTC
Markus, sorry for the nag, but have you been able to make any progress? Thanks.
Comment 33 Sumana Harihareswara 2012-11-16 23:59:47 UTC
Actually, https://gerrit.wikimedia.org/r/#/c/23644/ is now merged, so is there anything blocking deployment?
Comment 34 Markus Glaser 2012-11-19 17:06:58 UTC
It's tentatively scheduled for deployment on test2 for today: http://wikitech.wikimedia.org/view/Software_deployments#Near-term_to_be_scheduled. So is there anything left to do?
Comment 35 Sumana Harihareswara 2012-11-21 18:54:34 UTC
It's deployed to test2 https://test2.wikipedia.org/wiki/Special:Version but unfortunately it depends on OggHandler and needs substantial coding to switch that dependency to TimedMediaHandler.  Anyone want to help?
Comment 36 Ryan Kaldari 2012-11-21 23:20:30 UTC
It should be fairly trivial to make the MIDI generation and audio player output configurable and/or dependent on the presence of OggHandler. Would make a good volunteer task :)
Comment 37 MZMcBride 2012-11-23 20:59:40 UTC
(In reply to comment #36)
> It should be fairly trivial to make the MIDI generation and audio player output
> configurable and/or dependent on the presence of OggHandler. Would make a good
> volunteer task :)

Is this a dependency? This bug (bug 33193) doesn't seem to have any other bug dependencies currently. (Surprisingly....) If there are small, discrete tasks that can be worked on, they should be filed as separate bugs and marked with the "easy" keyword.

As it is, I'm not sure what the path forward for this bug is at the moment.
Comment 38 Andre Klapper 2013-02-25 18:59:30 UTC
Markus: Would you have some time to address comment 35 by hacking on audio player output etc.?
(Just asking as you're the assignee of this bug report.)
Comment 39 Markus Glaser 2013-02-28 15:36:20 UTC
Andre: it seems that bug 43388 has been assigned to jgerber by now.
Comment 40 Greg Grossmeier 2013-03-20 17:49:43 UTC
Tim: So, just to be explicit, we're at a point where this could be deployed to the cluster?

If so, let's do this by the end of the month, probably by scheduling a deployment window where you are available since I believe you would be able to diagnose potential issues. Thanks.
Comment 41 MZMcBride 2013-03-20 18:03:57 UTC
(In reply to comment #40)
> Tim: So, just to be explicit, we're at a point where this could be deployed
> to the cluster?

No. I just filed bug 46374 ("Score extension broken on test2.wikipedia.org"). And bug 43388 ("Make Extension:Score use TimedMediaHandler for MIDI") is still unresolved.

I'd like to see the Score extension enabled and working on test2.wikipedia.org and test.wikipedia.org for a bit before wider deployment.
Comment 42 Greg Grossmeier 2013-04-17 16:46:15 UTC
Ok, so, Score works on test2, see https://test2.wikipedia.org/wiki/Score

Tim/Markus: anything else in your queue on this bug that needs fixing?
Comment 43 MZMcBride 2013-04-17 23:04:11 UTC
I'm neither Tim nor Markus, but this seems good to go to me. I re-read this bug and it seems all of the known outstanding issues have been resolved.

This needs a deployment window.
Comment 44 Rob Lanphier 2013-04-22 19:09:53 UTC
Which wikis should we deploy this to?  Seems that Wikipedia, Wikisource, and Commons are the obvious targets, though there doesn't seem to be any reason to restrict it from any wiki.  Also, all at once, or staged?
Comment 45 Sam Reed (reedy) 2013-04-22 19:17:49 UTC
(In reply to comment #44)
> Which wikis should we deploy this to?  Seems that Wikipedia, Wikisource, and
> Commons are the obvious targets, though there doesn't seem to be any reason
> to
> restrict it from any wiki.  Also, all at once, or staged?

Just default it on

It's not going to be used instantaneously everywhere due to it being quite a niche feature, and at the same time isn't going to annoy people by making stuff appear that hasn't been requested.

Make a window and turn it on. Any problems with it are only really going to come up with people using it

I guess I might aswell take this bug
Comment 46 Gerrit Notification Bot 2013-04-22 19:19:01 UTC
Related URL: https://gerrit.wikimedia.org/r/60309 (Gerrit Change I750caf1fe9f0ae2d428f70f11e46fdc4292fd409)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links