Last modified: 2012-10-04 09:53:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 33174 - All the pages of Bengali wiki loads twice for the webfonts
All the pages of Bengali wiki loads twice for the webfonts
Status: RESOLVED INVALID
Product: MediaWiki extensions
Classification: Unclassified
WebFonts (Other open bugs)
unspecified
PC All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
Depends on:
Blocks: 40760
  Show dependency treegraph
 
Reported: 2011-12-15 20:13 UTC by Nasir Khan Saikat
Modified: 2012-10-04 09:53 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screen capture at the time of page load (144.10 KB, video/mp4)
2011-12-20 09:55 UTC, Nasir Khan Saikat
Details

Description Nasir Khan Saikat 2011-12-15 20:13:50 UTC
I have tested this extension for the Bengali wikipedia form some of the browsers (Firefox 7 & 8 from windows 7 and XP, Chrome 15.0 windows 7 and XP, Firefox 7 form Uubntu 11.10) in different machines and in every case i had to face the same problem, that the page loads twice and takes an extra time for each of the pages. 

At the very first time the page loads with the system default font and then the whole page became empty and after that the browser shows the content with the selected web font.

and it takes some extra time to show the full page. 

thanks
nasir khan saikat
Wikimedia Bangladesh
Comment 1 Santhosh Thottingal 2011-12-19 11:03:21 UTC
This  is called FOUT, Flash Of Unformattes/Unstyled Text. And inherent with webfont technology, eventhough browsers are trying to reduce the impact on user experience. When you visit a page, the font is also getting downloaded just after browser understand that a font need to be downloaded. Firefox shows the page in default font, and when font is downloaded, it shows the text in that font. This causes a flickering in the screen, but it is not loading twice, its rendering twice. Some other browsers just display a blank space for the text and start rendering it only when font is downloaded, so there is no double rendering, but blank page for a few (milli)seconds.

But this behavior happens only when you download the font for fist time, ie when you visit a wiki with webfont for first time. Second time onwards browsers should use the font from cache.

Read more about it on http://paulirish.com/2009/fighting-the-font-face-fout/

Yes, time taken for page will be a little extra than the time taken for page without webfont. But all these are much visible only at the first use of webfont. when you navigate to other wikipages, it will be normal since font is not getting downloaded and used from cache.
Comment 2 Srikanth Logic 2011-12-19 11:22:41 UTC
And I guess if bug 33027 is fixed / performance is improved (In terms of bandwidth consumed, memory used on client side {though getting these data might be difficult and then getting delta improved might be even more difficult}), FOUT effect will be much shorter even for the first time the font gets download.
Comment 3 Siebrand Mazeland 2011-12-19 13:25:38 UTC
Please submit proof that pages are loaded twice, for example using a firebug screenshot. Bug 33027 is not directly related.
Comment 4 Nasir Khan Saikat 2011-12-20 09:55:53 UTC
Created attachment 9749 [details]
screen capture at the time of page load

i have attached a video where you can see the page load. hope this might be helpful .
it is captured form Windows 7 Google Chrome web browser
Comment 5 Siebrand Mazeland 2011-12-20 10:00:00 UTC
Thanks for the video in comment 4.

As explained in comment 1, this is FOUT, and not the page being loaded twice (it's being rendered twice, if anything, once without styling, once with styling). Some additional confusion is added into the mix by the fundraising banner pushing the page down. Your observation is expected behaviour.

I think this issue should be closed INVALID.
Comment 6 Santhosh Thottingal 2011-12-20 10:11:24 UTC
I am closing thiis bug since what we observed is expected behavior. If you navigate to some pages in the wiki, you wont see this because font is cached.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links