Last modified: 2013-07-09 21:58:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 33018 - unresponsive script message for FF 5.0
unresponsive script message for FF 5.0
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WebFonts (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
aklapper-moreinfo
: i18n
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 05:52 UTC by sodabottle
Modified: 2013-07-09 21:58 UTC (History)
7 users (show)

See Also:
Web browser: Firefox
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot of unresponsive script - ff 5.0, winxp sp2 (134.24 KB, image/jpeg)
2011-12-13 05:52 UTC, sodabottle
Details
Same error on pageload for a 240k article (132.56 KB, image/jpeg)
2011-12-13 06:13 UTC, sodabottle
Details

Description sodabottle 2011-12-13 05:52:50 UTC
Created attachment 9667 [details]
Screenshot of unresponsive script - ff 5.0, winxp sp2

Was testing webfonts in Telugu wikipedia, when i got this error. The page is 80k in size and takes about 4-5 seconds every time to render when webfont is selected.

When i tried to edit it (not sectionwise edit, full page edit) as a logged in user, i got this unresponsive script error. This happens when i choose Lohit and try to save or preview. If i turn off webfonts, the page is not sluggish and no error comes.

Browser : Firefox 5.0
OS : Win XP SP2
Comment 2 sodabottle 2011-12-13 06:11:49 UTC
Was able to reproduce same "unresponsive script" message for page load itself for a bigger article (http://te.wikipedia.org/wiki/%E0%B0%9C%E0%B0%B0%E0%B1%8D%E0%B0%AE%E0%B0%A8%E0%B1%80 ; size 240k ) - screenshot attached

I guess this is a problem with page size + webfont rendering overwhelming my browser (it takes nearly 10-15 seconds for rendering and 6-7 seconds of it is a whitescreen). It takes nearly 25 seconds after i hit enter to scroll/edit the page. (My internet connection is 300kbps in theory)
Comment 3 sodabottle 2011-12-13 06:13:22 UTC
Created attachment 9668 [details]
Same error on pageload for a 240k article

For comment 2
Comment 4 Sam Reed (reedy) 2011-12-13 10:07:58 UTC
Is there a reason you're stuck on FF5?

v8 is the current release, and it should just automatically upgrade for you...
Comment 5 sodabottle 2011-12-13 10:14:06 UTC
I have both FF5 and FF8 and prefer to use 5 because of lower memory usage. For webfonts i am testing for older versions of browsers. (FF 5, 4 and IE 7) In Indic environment, people with older boxes and browsers are the target audience for Webfonts. (Anyone who uses a post 2008 windows machine will have no need for webfonts). So testing from their perspective. 

BTW some other interesting things happen in FF 8 too. Will be filing bugs for them later.
Comment 6 Srikanth Logic 2011-12-13 10:28:36 UTC
Ideally I would say FF 3.x and FF 4.x must be tested. There are people who will not upgrade their browser / OS since they have 1 GB RAM boxes and these are the boxes that one can typically find in a non-tech Indian home(Many "might" have Indic fonts, but thats a different thread). I would also add to run the same tests on 1 GB RAM / 200 Kbps connections and do some profiling of code to improve performance.
Comment 7 Brion Vibber 2011-12-13 11:18:49 UTC
Note that Mozilla has been actively working on lowering memory usage over the last year, so you're probably better off with the current versions than the old ones.
Comment 8 sodabottle 2011-12-14 18:19:27 UTC
Thanks Brion. Mozilla has been giving the same reply since v6.0. But AFAIK there has been no real improvement - for every new version, the same complaints are raised by people in mozilla support forums. I have no addons and plugins and still i have to terminate and restart firefox every few hours. Even now my FF8.0 consumes roughly double the memory my FF5.0 consumes for the same browsing behavour.
Comment 9 Santhosh Thottingal 2012-07-14 22:51:27 UTC
sodabottle, do you still face this issue? Was it improved or did you upgrade your browser?
Comment 10 Andre Klapper 2012-10-09 10:58:51 UTC
Cannot reproduce with link in comment 2 and Firefox 15.0.1 on Fedora 16 Linux.

sodabottle: Is this still a problem with a recent and supported Firefox version (15.0.1 or 10.0.7esr), or can this report be closed as RESOLVED nowadays?
Comment 11 Siebrand Mazeland 2012-10-09 15:43:16 UTC
Marking resolved. Srsly, update if you're still using FF 5 or before.
Comment 12 Derk-Jan Hartman 2013-07-09 21:24:34 UTC
If FF5 isn't supported, ULS shouldn't load for FF5. This is now a default deployed extension for every en.wp page view and cannot be disabled by users. It should not break browsers in this fashion and should take some care to not break. We have gadget rules on en.wp that are stricter in terms of graceful breaking.

However I suspect that this has nothing to do with FF5, just with bug 50836

Until properly analyzed, REOPENED.
Comment 13 Nemo 2013-07-09 21:58:35 UTC
(In reply to comment #12)
> If FF5 isn't supported, ULS shouldn't load for FF5. This is now a default
> deployed extension

Webfonts has been disabled, so this is surely not true. :)
Bug 49935 is basically the reincarnation of this bug in ULS.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links