Last modified: 2013-10-23 18:16:57 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 32970 - MW 1.18; How to determine the search profile / setting of a default search profile
MW 1.18; How to determine the search profile / setting of a default search pr...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
1.18.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 32705 (view as bug list)
Depends on:
Blocks: documentation
  Show dependency treegraph
 
Reported: 2011-12-11 20:17 UTC by MWJames
Modified: 2013-10-23 18:16 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MWJames 2011-12-11 20:17:32 UTC
In MW 1.18 additional hooks have been added to enhance the Search profiling and especially creating your own profile works quite well but somehow it is nowhere to find the possibility the predetermine which profile to use as default. Since 1.18 the standard search always assumes to use profile=advanced which makes having additional profiles nice but not really convenient as the user has to change  profiles manually (neither the user preference nor the LocalSettings have a possibility to default a specific profile).

Our question is did we miss the documentation which explains how to set a default profile or is just by standard that the search uses profile=advanced as default profile?

I can guess, people will say that this is the intended behaviour and not an error but to assume that the standard search profile should always be profile=advanced is a bit short sighted now that we have such nice hooks.

[1] SpecialSearchProfiles, SpecialSearchProfileForm
Comment 1 MWJames 2011-12-23 08:31:13 UTC
We came across SpecialSearch.php (MW 1.18) line 104 which says:

>>>
if ( $profile === null) {
	$this->profile = 'advanced';
>>>

Instead of assuming option 'advanced' where $profile is empty, it certainly would be more convenient to check for a global variable, use a hook or just have a user option to decided which profile to be used as default.
Comment 2 MWJames 2011-12-27 02:57:34 UTC
*** Bug 32705 has been marked as a duplicate of this bug. ***
Comment 3 Bawolff (Brian Wolff) 2011-12-27 04:12:15 UTC
CC'ing Nikerabbit since i believe he was involved in adding the SpecialSearchProfileForm hook.
Comment 4 Niklas Laxström 2011-12-27 07:59:31 UTC
It's already fixed on trunk that it defaults to "default" profile instead of advanced.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links