Last modified: 2014-01-02 18:59:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 32770 - Replace $wgPasswordSenderName with a system message defaulting to "{{SITENAME}}" to clarify and allow translation
Replace $wgPasswordSenderName with a system message defaulting to "{{SITENAME...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: High normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.google-melange.com/gci/tas...
gci2013
: easy, i18n
: 33601 (view as bug list)
Depends on:
Blocks: 1932
  Show dependency treegraph
 
Reported: 2011-12-02 14:38 UTC by Maarten Dammers
Modified: 2014-01-02 18:59 UTC (History)
14 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Maarten Dammers 2011-12-02 14:38:31 UTC
I just got a notification mail from the English Wikipedia. The from fields is somewhat confusing:

From: MediaWiki Mail <wiki@wikimedia.org>

Should probably be changes to something like "Wiki[mp]edia notification system" or something in that direction. The current from field adds to the Mediawiki/Wikimedia/Wikipedia confusion.
Comment 1 Mark A. Hershberger 2011-12-02 17:04:18 UTC
Looks like $wgPasswordSenderName needs to be set correctly.
Comment 2 Sam Reed (reedy) 2011-12-05 17:02:43 UTC
If we decide what we want it to be, we can configure it
Comment 3 Maarten Dammers 2012-01-01 15:35:51 UTC
Please set $wgPasswordSenderName to "$wgSitename Mail". That's probably something like "$wgPasswordSenderName = $wgSitename . ' Mail';" in the configuration.
Comment 4 Daniel Zahn 2012-01-02 15:35:30 UTC
Is this an ops request to just change the current config for all projects? If yes, i see we are setting $wgPasswordSender = 'wiki@wikimedia.org'; in wmf-config/CommonSettings.php but i don't see $wgPasswordSenderName there. Is that because it was already supposed to be a per-project setting? But if we follow the suggestion we can just add it in CommonSettings.php

Besides that, is it also a Dev request to change the default settings in Mediawiki releases?
Comment 5 Mark A. Hershberger 2012-01-03 02:12:18 UTC
(In reply to comment #4)
> Is this an ops request to just change the current config for all projects?

> Besides that, is it also a Dev request to change the default settings in
> Mediawiki releases?

I think it could be considered  both.  See discussion on wikitech-l:

http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/57942
Comment 6 Strainu 2012-01-03 15:04:32 UTC
(In reply to comment #3)
> Please set $wgPasswordSenderName to "$wgSitename Mail". That's probably
> something like "$wgPasswordSenderName = $wgSitename . ' Mail';" in the
> configuration.

This SHOULD be localized, so wouldn't it be simpler to just have a message for this, which defaults to "{{SITENAME}} Mail"?
Comment 7 Nemo 2012-01-09 07:34:25 UTC
Clarified summary per [[mw:New Editor Engagement/Email notifications]] and wikitech thread.
Comment 8 Sam Reed (reedy) 2012-01-09 19:25:09 UTC
(In reply to comment #6)
> (In reply to comment #3)
> > Please set $wgPasswordSenderName to "$wgSitename Mail". That's probably
> > something like "$wgPasswordSenderName = $wgSitename . ' Mail';" in the
> > configuration.
> 
> This SHOULD be localized, so wouldn't it be simpler to just have a message for
> this, which defaults to "{{SITENAME}} Mail"?

I'm presuming in WikimediaMessages?
Comment 9 Strainu 2012-01-09 20:53:54 UTC
I have no idea what you understand by WikimediaMessages, but anyhow, I've logged a separate bug for the localization (bug 33601), since localizing means writing code, while this bug is only a site request.
Comment 10 Sam Reed (reedy) 2012-01-13 00:51:51 UTC
(In reply to comment #9)
> I have no idea what you understand by WikimediaMessages, but anyhow, I've
> logged a separate bug for the localization (bug 33601), since localizing means
> writing code, while this bug is only a site request.

Wikimedia-specific messages (it's an extension), where things like this usually go...
Comment 11 Siebrand Mazeland 2012-03-19 16:02:17 UTC
This shouldn't be about the WikimediaMessages extension or site requests for any specific wiki. I think that the default sender of e-mails should be reasonably identifiable, in the content language and configurable in-wiki (i.e. a system message). Something that includes SITENAME seems appropriate (and the sender name should support GRAMMAR). I'd suggest "{{SITENAME}} mail" (similar to comment 1, just not title cased).
Comment 12 Strainu 2012-03-19 16:27:01 UTC
Siebrand, I've logged bug 33601 for the localization issue. I guess I was hoping this can be fixed sooner in configs and later on in the code (to actually have it localized). If you make this an i18n bug, please mark 33601 as a duplicate.
Comment 13 Siebrand Mazeland 2012-03-19 18:39:09 UTC
*** Bug 33601 has been marked as a duplicate of this bug. ***
Comment 14 Nemo 2012-03-19 20:32:31 UTC
Changing summary too.
Siebrand, I may have lost track of the discussion, but why did you add "mail"? Isn't it easier to just drop it? Anyway, if it's configurable on wiki it's not a problem and I don't want to bikeshed, so let's just do it! :)
Comment 15 Siebrand Mazeland 2012-03-19 21:20:09 UTC
Indeed :)
Comment 16 Krinkle 2012-03-29 11:29:12 UTC
currently:
$wgPasswordSenderName = 'MediaWiki Mail';

Proposals so far:

1)

* deprecate $wgPasswordSenderName
* replace it by an interface message that will be localized via translatewiki.net (e.g." {{SITENAME}} Mail" as value for English) (in mediawiki core that is, not Wikimedia specific at all)
* as a side-effect allows local wikis to override it, do we want that? do we need that?

2)
* deprecate $wgPasswordSenderName
* Just use $wgSiteName

3)
* keep as is?
Comment 17 Strainu 2012-03-29 13:13:07 UTC
(In reply to comment #16)
> * as a side-effect allows local wikis to override it, do we want that?

Yes, you do. You just might not know that yet... :)

(In reply to comment #16)
> do we need that?

If by "we" you mean the Wikimedia wikis, probably not. It will most likely remain unchanged in most projects. But for external wikis (especially hosted ones), it might be cool to be able to change that without changing the config.
Comment 18 Daniel Friesen 2013-03-19 09:55:00 UTC
(In reply to comment #14)
> Changing summary too.
> Siebrand, I may have lost track of the discussion, but why did you add
> "mail"?
> Isn't it easier to just drop it? Anyway, if it's configurable on wiki it's
> not
> a problem and I don't want to bikeshed, so let's just do it! :)

+1

Seeing the mail reader say "You have new messages from Wikipedia" in a notification sounds more natural than "You have new messages from Wikipedia mail".
Comment 19 Nemo 2013-07-26 06:46:18 UTC
Relatedly, the Echo extension seems to be partially doing something like this (while adding a ton of other issues in enotifs), but I have no idea if it's configurable. See for instance how a welcome message looks like on en.wiki: https://www.mediawiki.org/w/index.php?title=Extension:GettingStarted/Welcome_enotif&oldid=686716
Comment 20 Nemo 2013-12-25 10:49:33 UTC
Quim, can you add this as GCI task? I should be able to review it, though not to merge.
Comment 21 Quim Gil 2013-12-27 06:46:13 UTC
Yes, I can create a Google Code-in task out of this report, but I would welcome a clear description added here. Currently it is not clear (to me) what is the solution expected. We want to send GCI students to tasks with a clear implementation. Thank you!
Comment 22 Nemo 2013-12-27 08:04:58 UTC
(In reply to comment #21)
> Yes, I can create a Google Code-in task out of this report, but I would
> welcome
> a clear description added here. Currently it is not clear (to me) what is the
> solution expected. We want to send GCI students to tasks with a clear
> implementation. Thank you!

The summary has summarised the discussion so far. It's about moving the configuration variable to a system message with a different default.
Comment 23 Quim Gil 2013-12-29 05:51:37 UTC
Thank you for the clarification. GCI task created.
Comment 24 Gerrit Notification Bot 2013-12-31 06:21:30 UTC
Change 104707 had a related patch set uploaded by Theopolisme:
Replace $wgPasswordSenderName with a system message

https://gerrit.wikimedia.org/r/104707
Comment 25 Gerrit Notification Bot 2014-01-02 18:14:18 UTC
Change 104707 merged by jenkins-bot:
Deprecate $wgPasswordSenderName

https://gerrit.wikimedia.org/r/104707
Comment 26 Siebrand Mazeland 2014-01-02 18:59:36 UTC
Gerrit change #104707 deprecates $wgPasswordSenderName and allows in-wiki configuration of the password sender name in the wiki page [[MediaWiki:Emailsender]], defaulting to {{SITENAME}} in the content language for all emails sent from MediaWiki core. Some extensions that send emails can still be using $wgPasswordSenderName and this is expected to be phased out over time.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links