Last modified: 2011-11-08 21:13:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 32262 - Renaming categories
Renaming categories
Status: RESOLVED DUPLICATE of bug 3311
Product: MediaWiki
Classification: Unclassified
Categories (Other open bugs)
unspecified
All All
: Unprioritized enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 13326
  Show dependency treegraph
 
Reported: 2011-11-08 15:38 UTC by DavidL
Modified: 2011-11-08 21:13 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description DavidL 2011-11-08 15:38:13 UTC
Currently categories cannot be renamed. The only possible action is to delete it, create another one (loosing history), and move all pages to the new category.

There should be a rename action for categories (like renaming pages) which should also updates all pages in the category, without loosing the category history.
Comment 1 Antoine "hashar" Musso (WMF) 2011-11-08 15:40:07 UTC
We can not do this until we get the category informations out of the wikitext :-(
Comment 2 Liangent 2011-11-08 15:42:16 UTC
Can we have "moving category page only" (without its members) so editing history can be preserved.
Comment 3 DavidL 2011-11-08 16:00:40 UTC
"moving category page only" feature would be great to have.
For page update, we may have to use a bot.
Comment 4 Bawolff (Brian Wolff) 2011-11-08 21:13:23 UTC

*** This bug has been marked as a duplicate of bug 3311 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links