Last modified: 2011-11-08 19:26:16 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 32253 - Certain special pages are static HTML pages, not dynamically self-refreshing
Certain special pages are static HTML pages, not dynamically self-refreshing
Status: RESOLVED DUPLICATE of bug 5560
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Unprioritized enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 01:47 UTC by Justin Anthony Knapp
Modified: 2011-11-08 19:26 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Justin Anthony Knapp 2011-11-08 01:47:52 UTC
Watchlists are--like all pages generated by MediaWiki software--static HTML. The display of their contents does not change as the content on the backend changes and new revisions are only viewable once the user refreshes the page or otherwise calls for it. Watchlists and certain other special pages (e.g. Speical:RecentChanges or Special:Contributions/User:FOO) should use some method of dynamically refreshing a la Gmail's inbox using XMLHttpRequest.
Comment 1 p858snake 2011-11-08 02:57:57 UTC
I actually prefer sites that don't auto refresh unless there is a absolute need for it, Apart from RecentChanges most of the special pages generally wouldn't be open long enough in my view to really need it.

Although there might be some tiny usability increases, auto refreshing also introduces a downsides such as when they try to reload when there isn't a available web connection that it will fail and bring up nasty browser error messages in most cases.

(I have lived on filtered net connections where I didn't have web after certain hours, And I like to leave stuff open and come back to it later and not have it errored out due to failed refreshes)
Comment 2 Justin Anthony Knapp 2011-11-08 03:00:08 UTC
What--if anything--would be lost if the option for dynamic pages was introduced? If users could opt-in or opt-out of XMLhttpRequest-type dynamic pages, that could be a solution and it would also work for non-JavaScript enabled browsers.
Comment 3 Antoine "hashar" Musso (WMF) 2011-11-08 16:06:45 UTC
not a bug but an enhancement request :D
Comment 4 Justin Anthony Knapp 2011-11-08 16:08:23 UTC
I didn't know if this was for "that's-not-a-bug-it's-a-feature"-style "bugs" as well, or just actual "I-can't-use-this"-style actual bugs. Should I take this to mediawiki.org?
Comment 5 Roan Kattouw 2011-11-08 19:25:05 UTC
(In reply to comment #4)
> I didn't know if this was for "that's-not-a-bug-it's-a-feature"-style "bugs" as
> well, or just actual "I-can't-use-this"-style actual bugs. Should I take this
> to mediawiki.org?
No, enhancement requests are fine here, that's why Antoine changed the severity to "enhancement".
Comment 6 Brion Vibber 2011-11-08 19:26:16 UTC
I'm just going to merge this in with bug 5560 and friends.

*** This bug has been marked as a duplicate of bug 5560 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links