Last modified: 2012-04-16 09:16:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31750 - No info about a self-redirected page is shown when it's queried with &redirects
No info about a self-redirected page is shown when it's queried with &redirects
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: documentation
  Show dependency treegraph
 
Reported: 2011-10-16 10:49 UTC by Liangent
Modified: 2012-04-16 09:16 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Liangent 2011-10-16 10:49:10 UTC
http://zh.wikipedia.org/w/api.php?action=query&prop=info&titles=User:Liangent/moretest&redirects

A <pages> section is expected but it's not there.
Comment 1 Mark A. Hershberger 2011-10-18 17:20:54 UTC
I think the documentation at http://www.mediawiki.org/wiki/API:Properties#info_.2F_in just needs to be updated.
Comment 2 Roan Kattouw 2011-10-25 15:19:04 UTC
Yeah, this is not a bug, just a documentation issue. You've hit a special case of a redirect loop. When the API encounters a redirect loop, it gives up and doesn't output a <page> tag for the redirect target (because there *is* no redirect target in case of a loop).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links