Last modified: 2013-09-02 07:34:00 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31371 - Assamese Vs Latin numerals in templates using parser functions, Set "$wgTranslateNumerals = false;" for aswiki
Assamese Vs Latin numerals in templates using parser functions, Set "$wgTrans...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: High major (vote)
: ---
Assigned To: Nobody - You can work on this!
: shell
Depends on:
Blocks: 40760
  Show dependency treegraph
 
Reported: 2011-10-05 09:03 UTC by Prabhakar Sarma Neog
Modified: 2013-09-02 07:34 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Prabhakar Sarma Neog 2011-10-05 09:03:19 UTC
Need to Set "$wgTranslateNumerals = false;" in LocalSettings.php of Assamese Wikipedia, http://as.wikipedia.org.

The following demonstrates the problem:
Latin Numerals: 0 1 2 3 4 5 6 7 8 9 Assamese Numerals: ০ ১ ২ ৩ ৪ ৫ ৬ ৭ ৮ ৯ (Bengali unicode)

Correct:

* {{#expr: 2 + 3}}: 5
* {{CURRENTYEAR}}: ২০১১

Error:

* {{#expr: ২ + ৩}}: এক্সপ্রেশন ত্রুটি: অপরিচিত বিরামচিহ্ন ক্যারেক্টার "�"
* {{#expr: 2 + ৩}}: এক্সপ্রেশন ত্রুটি: অপরিচিত বিরামচিহ্ন ক্যারেক্টার "�"
* {{#expr: {{CURRENTYEAR}} + 10}}: এক্সপ্রেশন ত্রুটি: অপরিচিত বিরামচিহ্ন ক্যারেক্টার "{"

Probable solutions:

1. {{#expr: {{formatnum: {{CURRENTYEAR}}|R}} + 10}}: 2021
2. Set "$wgTranslateNumerals = false;" in LocalSettings.php


The first solution is not acceptable since there are a lot of templates where functions like {{CURRENTYEAR}}, {{CURRENTDAY}} etc are used. So, we need to modify LocalSettings.php as shown above.

See templates like "Infobox Indian Jurisdiction", "Infobox Settlement" etc. You can also see how modification using "formatnum" works in the template "For year month day" in Assamese Wikipedia.

We have conducted a poll and the community agrees to this. See: 
https://secure.wikimedia.org/wikipedia/as/wiki/Wikipedia:Community_Votes#Assamese_Vs_Latin_numerals_in_templates_using_parser_functions
Comment 1 Niklas Laxström 2011-10-05 14:19:30 UTC
Rest of my comment in bug 14145 applies here too:

I don't understand why you want to sacrifice usability of readers to get some
convenience for advanced editors editing templates. It seems to me that you
have not thought out this issue properly.
Comment 2 Sam Reed (reedy) 2011-10-05 14:49:11 UTC
Done
Comment 3 Prabhakar Sarma Neog 2011-10-05 16:43:49 UTC
Thanks.

@Niklas: Right, we could have solved the problem by editing some templates or even patching the code related to the magic words like {{CURRENTDAY}} etc. But, we, or at least the Assamese community are accustomed using Latin numerals and symbols in mathematics starting from primary schools and even in our daily lives. Some other Indian language communities, like the Hindi users also follow the same convention.  Apart from that English numerals are very common in India and almost everyone can understand them.   

Basically this is the reason we have adopted this approach.
Comment 4 Siebrand Mazeland 2011-10-05 16:45:21 UTC
Sam, did you take comment 1 into account when complying with the request in the
original call, and it so can you please provide insight in how you weighed pros
and cons?
Comment 5 Prabhakar Sarma Neog 2012-02-03 11:35:04 UTC
*** Bug 34174 has been marked as a duplicate of this bug. ***
Comment 6 Jayanta Nath 2012-02-03 16:27:09 UTC
instead of magic word {{CURRENTYEAR}} Bengali Wikipedia use this {{#time:xnY}}
Comment 7 Jayanta Nath 2012-02-03 16:28:22 UTC
Only  big issue is #time parser function can't read local language month names
https://bugzilla.wikimedia.org/show_bug.cgi?id=19412
Comment 8 Prabhakar Sarma Neog 2012-02-03 18:44:59 UTC
*** Bug 34193 has been marked as a duplicate of this bug. ***
Comment 9 Prabhakar Sarma Neog 2012-02-03 19:19:09 UTC
*** Bug 34174 has been marked as a duplicate of this bug. ***
Comment 10 Prabhakar Sarma Neog 2012-02-03 19:22:03 UTC
*** Bug 34193 has been marked as a duplicate of this bug. ***
Comment 11 Nemo 2012-11-17 15:47:34 UTC
(In reply to comment #4)
> Sam, did you take comment 1 into account when complying with the request in the
> original call,

Looks not: the request was satisfied.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links