Last modified: 2014-09-25 12:34:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 30437 - change the default Hebrew font
change the default Hebrew font
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Collection (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-18 10:51 UTC by Amir E. Aharoni
Modified: 2014-09-25 12:34 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
test pdf with taamy frank font (97.31 KB, application/pdf)
2011-08-18 13:09 UTC, Volker Haas
Details
test pdf with freefont (60.06 KB, application/pdf)
2011-08-18 13:09 UTC, Volker Haas
Details
Screenshot of Browser displaying hebrew text (140.58 KB, image/jpeg)
2012-01-11 09:39 UTC, Volker Haas
Details

Description Amir E. Aharoni 2011-08-18 10:51:48 UTC
The PDF export started working in right-to-left languages recently, which is very good, and the extension was enabled on the Hebrew Wikipedia. However, the default font for Hebrew seems to be Ezra, which is a very old-fashioned font.

Please change the default font for Hebrew to Taamey Frank CLM. It is a freely-licensed font, that can be downloaded here:

http://culmus.sourceforge.net/taamim/index.html

Thank you.
Comment 1 Volker Haas 2011-08-18 13:09:06 UTC
Created attachment 8936 [details]
test pdf with taamy frank font

source: http://he.wikipedia.org/w/index.php?title=%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9:Volker.haas&oldid=11064831
Comment 3 Volker Haas 2011-08-18 13:13:23 UTC
Unfortunately the diacritics(?) are misplaced when using the Taamy Frank font. Currently we are using Freefont where this is not an issue. See the two test PDFs I attached

Do you have another suggestion for a better font than what is currently used?
Comment 4 Amir E. Aharoni 2011-08-18 13:20:51 UTC
Hmm :/

Thanks for the quick response.

This is quite strange, because Taamey Frank was designed to support diacritics well. This may be a problem in the rendering library.

Can you please try this with SBL Hebrew ( http://www.sbl-site.org/educational/BiblicalFonts_SBLHebrew.aspx )? It's not freely-licensed and its style is also quite old, but everyone agrees that its diacritics support is superb. If it doesn't work with SBL Hebrew, than it's definitely a problem in the rendering library.
Comment 5 Volker Haas 2011-08-18 13:27:40 UTC
The result with SBL Hebrew is the same as with Taamey Frank (broken). Your assumption that it's the rendering engines fault is probably correct. But: fixing the rendering engine is very hard. Therefore I vote for using a font which works with the "broken" rendering engine. 

You're welcome to make more font suggestions, I'll render sample and upload the results if they look promising.
Comment 6 Amir E. Aharoni 2011-08-18 13:29:47 UTC
Oh well.

It's a rather curious bug. Can you please send me the font file that you are using now? I can ask the developer of Taamey Frank to compare them.
Comment 7 Volker Haas 2011-08-18 13:40:10 UTC
Currently GNU FreeFont is used. On debian/ubuntu it's the package 'ttf-freefont'. Alternatively you can download them here:

http://ftp.gnu.org/gnu/freefont/

We are currently using http://ftp.gnu.org/gnu/freefont/freefont-ttf-20090104.tar.gz

Some investigation reveals the source of the hebrew glyphs:

http://www.gnu.org/s/freefont/sources/index.html

--> http://culmus.sourceforge.net/
Comment 8 Volker Haas 2011-08-18 13:43:26 UTC
Note:
In another ticket [1] I was made aware of the discussion about a bug in mozilla firefox which might be related [2]. But I am just guessing here.

But you should also keep in mind that the rendering engine we are using was never designed to work with complex scripts...therefore the bug might be quite random


[1] https://bugzilla.wikimedia.org/show_bug.cgi?id=30326
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=635639
Comment 9 Amir E. Aharoni 2011-08-23 06:38:28 UTC
Original description suggested the Taamey Frank CLM font. I made it more generic.
Comment 10 Amir E. Aharoni 2012-01-02 13:01:17 UTC
Volker, can you please send me the rendering of the following web page on the same computer on which you created the PDF files? Please indicate the browser version and the operating system version. Thank you.
Comment 11 Volker Haas 2012-01-10 13:49:22 UTC
Amir, I believe you forgot to include the URL in your previous comment.
Comment 12 Amir E. Aharoni 2012-01-10 13:51:33 UTC
Here it is:

http://culmus.sourceforge.net/taamim/index.html

Taamey David CLM and Taamey Frank CLM are both OK.
Comment 13 Amir E. Aharoni 2012-01-10 13:52:27 UTC
Oh, i'm totally confused.

Here's the page:

http://translatewiki.net/wiki/User:Amire80/hbo
Comment 14 Volker Haas 2012-01-11 09:38:38 UTC
Unfortunately I can't access the computer that was used for the inital PDF renderings. But the machine at my disposal now, should have a pretty identical configuration regarding fonts.

The screenshot I'll attach was done with Firefox 9.0.1 on Xubuntu 11.10
Comment 15 Volker Haas 2012-01-11 09:39:38 UTC
Created attachment 9839 [details]
Screenshot of Browser displaying hebrew text
Comment 16 Amir E. Aharoni 2012-02-07 17:29:42 UTC
Hmm, the browser screenshot is fine, but the PDF is broken.

Can you maybe switch the font rendering to something like Harfbuzz? It should render it well.
Comment 17 Volker Haas 2012-02-09 05:42:20 UTC
I can't switch the rendering engine. We are using a python framework that uses it's own rendering engine. Switching the rendering engine means rewriting all the software involved with PDF rendering. Also there are downsides to alternative rendering engines - we would trade some current shortcomings with some other problems.

For the problem with the misplaced diacritics for the Taamy Frank font: this can be worked around if the font file is manually tweaked. I know this is somewhat silly, but currently the only solution I see to the problem. This workaround has been done for an arabic font where the exact same problem occured. Unfortunately I am not able to find the ticket right now.
Comment 18 Nemo 2014-09-25 11:52:44 UTC
(In reply to Amir E. Aharoni from comment #0)
> The PDF export started working in right-to-left languages recently, which is
> very good, and the extension was enabled on the Hebrew Wikipedia. However,
> the default font for Hebrew seems to be Ezra, which is a very old-fashioned
> font.

(In reply to Volker Haas from comment #1)
> http://he.wikipedia.org/w/index.php?title=%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9:
> Volker.haas&oldid=11064831

What font is used now?
https://he.wikipedia.org/w/index.php?title=%D7%9E%D7%99%D7%95%D7%97%D7%93:%D7%A1%D7%A4%D7%A8&bookcmd=render_article&arttitle=%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9%3AVolker.haas&oldid=11064831&writer=rdf2latex
Comment 19 Amir E. Aharoni 2014-09-25 12:34:32 UTC
A better one, probably one of the Culmus Frank fonts. Essentially fixed. Thanks for the ping.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links