Last modified: 2011-08-15 20:58:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 30360 - Create ISBN-like links for ships with associated special page (e.g. for Commons or other projects)
Create ISBN-like links for ships with associated special page (e.g. for Commo...
Status: RESOLVED DUPLICATE of bug 26207
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Unprioritized enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-13 10:59 UTC by User:Docu
Modified: 2011-08-15 20:58 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description User:Docu 2011-08-13 10:59:42 UTC
Similar to projects, it could be worth allowing other magic links and creating special pages for other type of identifiers. 

These could be enabled on a project specific basis. Projects could decide to activate these.

For ships, the following could be interesting: MMSI, IMO, ENI

Possible features: 
* validation if a checksum is involved
* linkify links
Comment 1 User:Docu 2011-08-13 11:04:34 UTC
Read "Similar to ISBN links" instead of "Similar to projects"
Comment 2 Sam Reed (reedy) 2011-08-13 11:33:05 UTC
This would probably be better as an extension, rather than littering core (that and the ISBN stuff is wanted to be stripped out of core anyway)
Comment 3 User:Docu 2011-08-14 10:38:22 UTC
I suppose once it's an extension, it would be easy to adapt ("easy" as in, I could do it myself?). 

Until it's done, maybe we could try to add "MMSI:" to core. It's seems fairly simple and the result would be most helpful.
Comment 4 User:Docu 2011-08-14 14:44:22 UTC
I added a sample patch to bug 26207

MMSI, IMO, ENI are 9/7/8-digit numeric.
Comment 5 Brion Vibber 2011-08-15 17:39:02 UTC
I'm going to go out on a limb and kill this actually; the preference these days is for less "magical" stuff and should instead be more explicit. (Among other things, using templates for this sort of thing avoids the problems of central maintenance, surprise links, parser level interference, etc)

Editing-time and review-time link helpers are probably a better way to go than more auto-linking.

Duping this specific bug to bug 26207.

*** This bug has been marked as a duplicate of bug 26207 ***
Comment 6 User:Docu 2011-08-15 20:58:08 UTC
As no other Wikimedia feature offers the options of ISBN linking (e.g. ISBN 123456789 links to [[Special:BookSources/123456789]]), there isn't really another way of implementing this.

Obviously, what may be appropriate for one wiki is not necessarily suitable for others. Thus the advantage making this an extension. The extension of bug 26207 isn't implemented yet, the feature might need to be built into core to be working.

Even if extension is built, we might still need to adapt it for the a/m identifiers.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links