Last modified: 2014-11-17 10:36:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 30345 - Create "Data Commons" or "Wikidata" project (tracking)
Create "Data Commons" or "Wikidata" project (tracking)
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: High enhancement with 3 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://strategy.wikimedia.org/wiki/Pr...
:
: 4706 (view as bug list)
Depends on:
Blocks: 167 7777 1911
  Show dependency treegraph
 
Reported: 2011-08-12 16:19 UTC by Jan Kucera (Kozuch)
Modified: 2014-11-17 10:36 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jan Kucera (Kozuch) 2011-08-12 16:19:12 UTC
According to proposal called "Proposal:Structured Data" on Strategy Wiki (http://strategy.wikimedia.org/wiki/Proposal:Structured_Data) and about 10 another similar proposals, we need to create a project for DATA. May this bug be tracking one for the whole DataCommons/WikiData project.

So far I understand the matter has been stuck rather because the technical solution is not clear, but I think there is an obvious need for the project.
Comment 2 Krinkle 2011-08-12 16:28:54 UTC
Random crap that I remember from past times this has been brough up on IRC,
Hackathons and Wikimania:

* We could use a (rewritten version of) Semantic Wiki ("rewritten" due to some issues, most notably the 'central wiki' part, as well as other major "issues")

* Write a new system to store key/value pairs, not associated to a page but
directly in a database interface
** version A: a SpecialPage that is a *little* bit like CentralAuth in that
it'd be a central table but not per se on a central wiki, editable by anyone
with the required global right
** version B: a SpecialPage that is only installed on the central wiki, major
difference with version A: The project would get it's own wiki (not just a talk
page on Meta-Wiki) and users would get user-rights for this specialpage on the
local wiki)

* (Abuse|Reuse|Use) the interwiki-transclusion system for this and store the
data as pages ("templates") on a central wiki which can be transcluded to any
wiki (optionally the interwiki transclusion would be limited to the
Template-namespace, or better a new namespace "Data:")
** wikipedia article: "Lorem ipsum dolor {{datawiki:Data:Foobar}} silet amet"
** As a side-effect / opportunity or silly idea (pick the one you prefer): We
could combine the data-wiki with the template-wiki for multi-langual/cross-wiki
templates. All it takes is setting the configuration to allow transclusion of
not just NS_DATA but also NS_TEMPLATE)

--
Krinkle
Comment 3 Jan Kucera (Kozuch) 2011-12-02 09:07:57 UTC
Wikimedia Germany started the project at: http://meta.wikimedia.org/wiki/WikiData_WMDE.
Comment 4 Diederik van Liere 2011-12-06 03:16:45 UTC
Should this become a new project in Bugzilla?
Comment 5 Jan Kucera (Kozuch) 2011-12-06 14:51:43 UTC
(In reply to comment #4)
> Should this become a new project in Bugzilla?

Well, I am not sure how the German guys want to handle the project at all... Better to ask them (at WMDE).
Comment 6 Helder 2012-04-14 18:00:05 UTC
*** Bug 4706 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper 2013-02-05 11:51:10 UTC
(In reply to comment #0)
> we need to create a project for DATA.

Work in progress: https://www.wikidata.org/
Comment 8 Andre Klapper 2013-04-25 16:57:51 UTC
Wikidata exists nowadays and is in use.

In Bugzilla, you can find "MediaWiki extensions > Wikidata*" and for server configuration there is "Wikimedia > Wikidata", plus a "wikidata" keyword.

Closing as FIXED. If there are specific unfulfilled aspects of this request, please check if they already exists against Wikidata and if not, file specific bug reports about them. Thanks!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links