Last modified: 2011-08-30 07:17:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29988 - Category, template, and form semantic metadata needed automatically for each page that uses them
Category, template, and form semantic metadata needed automatically for each ...
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
Semantic MediaWiki (Other open bugs)
unspecified
All All
: Lowest enhancement (vote)
: ---
Assigned To: Markus Krötzsch
:
: 13151 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-20 20:52 UTC by badon
Modified: 2011-08-30 07:17 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description badon 2011-07-20 20:52:10 UTC
We already get property data in the factbox, which is very handy for developing, maintaining, and using a semantic mediawiki. All that remains to be added is information about categories, templates, and forms that are used for the page. Likewise, categories, templates, and forms could also have information about which of those three things go into defining them (like if a template is created by a form, or if a category is contained in a template).

I have been able to manually add these features to this page (user Demo, pass dedauw):

http://www.coincompendium.com/wiki/index.php/File:1989GWWcto.jpg

Wiki developers, maintainers, and users can easily access the categories, templates, and forms that go into creating that page, all in place. In addition, I'm able to query the semantic data to display on the template page which pages are using the template:

http://www.coincompendium.com/wiki/index.php/Template:Image

The nature of these things makes it straightforward to add them manually once, and then use them unlimited numbers of times. However, if the properties "Category", "Template", and "Form" were part of the metadata of each page, they could be displayed in the factbox that already handles other properties. 

Also, my factboxes do not show special metadata properties like the "Modification date" property that currently exists - this should be at least optional, if not the default).

See also: https://bugzilla.wikimedia.org/show_bug.cgi?id=13151
Comment 1 Jeroen De Dauw 2011-08-29 15:13:13 UTC
*** Bug 13151 has been marked as a duplicate of this bug. ***
Comment 2 Jeroen De Dauw 2011-08-29 15:17:24 UTC
You reported the "need for more special properties" in 3 different bug reports, please stick with 1. As Markus suggests in bug 13151, this is material for an extension, ie not for SMW itself.

> Also, my factboxes do not show special metadata properties like the
"Modification date" property that currently exists - this should be at least
optional, if not the default).

Having this as an option would be neat indeed - valid enhancement request.
Comment 3 badon 2011-08-29 17:31:43 UTC
Should that final valid factbox enhancement request be put into its own report, and this one marked as resolved/wontfix?
Comment 4 Jeroen De Dauw 2011-08-29 17:53:00 UTC
That would be nice yes.
Comment 5 badon 2011-08-30 07:17:56 UTC
Closed this bug, and made a new one that's specific to the one aspect of this bug that was distilled out:

https://bugzilla.wikimedia.org/show_bug.cgi?id=30628

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links