Last modified: 2013-06-18 15:38:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29087 - Enable $wgPFEnableStringFunctions on he.wikipedia
Enable $wgPFEnableStringFunctions on he.wikipedia
Status: RESOLVED WONTFIX
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
https://secure.wikimedia.org/wikipedi...
: patch-need-review
Depends on: 6455
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-22 09:28 UTC by matanya
Modified: 2013-06-18 15:38 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description matanya 2011-05-22 09:28:32 UTC
please enable $wgPFEnableStringFunctions = true in local settings on he.wikipedia.
thanks in advance.
Comment 3 Sam Reed (reedy) 2011-05-22 12:40:12 UTC
I believe string functions are disabled for a reason... (ie they give crap performance)
Comment 4 Krinkle 2011-05-22 12:41:54 UTC
Machine translation from the given wiki section:

> == $wgPFEnableStringFunctions ==
> Hello.
> We already have expansion ParserFunctions. This extension allows additional 
> functionality, especially the majority (if not all) functions were extensively 
> StringFunctions old. The problem is that additional functionality is controlled by 
> a flag in LocalSettings (see title), this flag we must not exist (or exists but with 
> a value of false). The specific reason I want the add-on function is mainly to
> replace: for example for a site Vyakirafvah, so that links will work to replace all spaces 
> in "_", which is also ugly and makes it impossible to use the name value directly 
> (see the example in even {{ Vyakirafvah }} now produces a broken link for 
> earnings). Is there a mode to add
> "; wgPFEnableStringFunctions = true $" to LocalSettings? (I also vaguely 
> remember that David Shay asked someone about the possibility of interchangeable 
> format, though I no longer remember the exact reason.)
> Thanks - Akipodnges - Talk 21:26, 20 May 2011 (UTC)
>> Should open a bug Ababagzilo, you want to do this, or am
>> I? waist • Talk 22:12, 21 May 2011 (UTC)
>>> You mean we have no control over our LocalSettings?
>>> I always thought that. If you do not mind I'd rather you not open
>>> - thanks. Akipodnges - Talk 22:38, 21 May 2011 (UTC)
>>>> I'll open a bug later today. Mattaniah • Talk 11:46, 22 May 2011 (UTC)
Comment 5 Bawolff (Brian Wolff) 2011-05-23 06:21:06 UTC
Should this be marked as a duplicate of bug 6455. From what I understand bug 6455 is essentially a no for all Wikimedia wikis (?)
Comment 6 p858snake 2011-05-23 06:26:16 UTC
(In reply to comment #5)
> Should this be marked as a duplicate of bug 6455. From what I understand bug
> 6455 is essentially a no for all Wikimedia wikis (?)

There are many things that won't get enabled cluster wide but will on smaller projects.

cc'ing tim so he can comment about it.
Comment 7 Brad Jorsch 2011-05-23 21:52:07 UTC
(In reply to comment #3)
> I believe string functions are disabled for a reason... (ie they give crap
> performance)

Last I heard, the reason was "We would rather have Lua or some other real language. Never mind that no one is working on it and the various requirements (e.g. a pure-PHP implementation must exist for use by people on crappy hosting who want to reuse Wikipedia templates) increase the work needed dramatically."
Comment 8 Tim Starling 2011-05-23 23:29:02 UTC
(In reply to comment #7)
> (In reply to comment #3)
> > I believe string functions are disabled for a reason... (ie they give crap
> > performance)
> 
> Last I heard, the reason was "We would rather have Lua or some other real
> language. Never mind that no one is working on it and the various requirements
> (e.g. a pure-PHP implementation must exist for use by people on crappy hosting
> who want to reuse Wikipedia templates) increase the work needed dramatically."

There is the InlineScripts extension now, which should already be better than StringFunctions for just about everything. Maybe we could enable it on Wikimedia if a little more work were done on it.
Comment 9 Rich Farmbrough 2011-07-17 08:24:32 UTC
http://www.mediawiki.org/wiki/Extension:InlineScripts

No documentation. Not even a description. (But thanks to Reedy for adding it to WMF in January.)

However functionality is visible at http://svn.wikimedia.org/svnroot/mediawiki/trunk/extensions/InlineScripts/interpreterTests.txt


This looks good, providing list manipulation, although it does duplicate a lot that we already have.  

What is the "little more work" that needs doing? And should we make a site request to enable it on Test?
Comment 10 Antoine "hashar" Musso (WMF) 2012-02-20 19:42:28 UTC
Closing as WONTFIX just like 6455. The string parser functions are too CPU intensive although they fill a valid need.

The current plan is to replace that kind of functions with a more robust solution (LUA) to handle that kind of user needs.

See also : https://bugzilla.wikimedia.org/show_bug.cgi?id=6455#c148
Comment 11 Rich Farmbrough 2012-02-24 15:24:22 UTC
Sigh. What we use now is too CPU intensive (far far more so than parser functions), though I have no problem with the WONTFIX since Lua is a coming. Some time...

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links