Last modified: 2013-04-08 11:01:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28710 - enhancement request: make frequently updated special pages update themselves automatically
enhancement request: make frequently updated special pages update themselves ...
Status: RESOLVED DUPLICATE of bug 5560
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-26 20:01 UTC by Amir E. Aharoni
Modified: 2013-04-08 11:01 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2011-04-26 20:01:11 UTC
It would be nice it frequently updated special pages, such as Recent Changes, Watchlist, Block log, Page creation log, page history and possibly others, would live-update themselves frequently, in the style of identi.ca. RC patrollers would probably appreciate it.
Comment 1 p858snake 2011-05-04 06:27:58 UTC
They do but several special pages on the WMF cluster are disabled due to load issues.

*** This bug has been marked as a duplicate of bug 15434 ***
Comment 2 p858snake 2011-05-04 06:28:40 UTC
whoops misread what you wrote.
Comment 3 Amir E. Aharoni 2011-06-17 15:28:23 UTC
Here's a website that does something similar: http://wikistream.inkdroid.org/
Comment 4 Helder 2012-05-04 17:31:50 UTC
Some user scripts which may be of interest:
* [[meta:User:Krinkle/Tools/Real-Time Recent Changes]]
* [[User:Lupin/Anti-vandal tool]]
Comment 5 Krinkle 2012-08-26 16:52:02 UTC
I'm closing this bug because imho it is too generic to be feasible.

(In reply to comment #0)
> It would be nice if frequently updated special pages, such as Recent Changes,
> Watchlist, Block log, Page creation log, page history and possibly others,
> would live-update themselves frequently, in the style of identi.ca. RC
> patrollers would probably appreciate it.

They are all special pages, and you could make a gadget in < 10 minutes that just polls itself and auto-refreshes with AJAX. That would work fine, but is not very flexible, efficient and has some usability issues (e.g. the page is replaced, and whatever you were doing is gone). So that is not a way we can do it in core, but one could create a gadget that does that.

Having said that, whatever the solution is going to be, it should be optimized for the specific use case. For example, for patrolling recent changes the (imho) most appropiate solution is to make use of a push feed in the browser and implement a proper patrolling workflow (see bug 5560 for that, which depends on bug 29305).

So for the most common use case requested in this bug, it is a dupe of bug 5560 / bug 29305.

The other examples (refreshing block log...), those are already covered by recent changes. And if so desired, it could be easily implemented on those individual special pages as well - that is, as soon as we have it working for the catch-all recent changes. (for the individual special pages one just tabs into the same feed, listen for rc.type=log where log_action is block, and then use the interface messages / html templates to inject list items on the page).

*** This bug has been marked as a duplicate of bug 5560 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links