Last modified: 2012-04-16 09:16:00 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28445 - pop up for definition of terms when reading an article
pop up for definition of terms when reading an article
Status: RESOLVED DUPLICATE of bug 503
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-06 20:25 UTC by Kshitiz Sethia
Modified: 2012-04-16 09:16 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Kshitiz Sethia 2011-04-06 20:25:12 UTC
When reading an article on wikipedia one mostly comes across terms which he has never heard of. At that time it is more necessary to keep reading on the article just by knowing the partial meaning of the term.

Currently, I click the hyperlink to the bigger article describing the term, read its introduction and come back. This is a big effort on my side IF I AM OFTEN BUMPING INTO UNKNOWN TERMS.

A SOLUTION to this could be a pop-up which has the introduction part of the article to which the hyperlink points. The pop-up would fire only if there is mouseOver for more than half or one second over the hyperlink. It would give the user a chance to keep his attention on the main article as well as explain the term to him.

Along with the pop-up we can have three more options:
 - If user clicks on the hyperlink, go to the article (obvious)
 - The user can add this article to a readQueue so that after he has finished reading the main article  he can go on and understand the finer details of the terms just read in brief.
 - hit 'Esc' key or hover mouse away to remove the pop-up.

IMPACT
 - Higher attention to the main article being read
 - More organized discovery of a new field. Let's say I'm a computer science student exploring Acturial Science, so it'll be easier for me to get brief definitions right now and add articles to my queue to read later on.

READ-QUEUE
 - A functionality which lets you decide the next article you want to read.
Can be session (cookie) based and/or account based (persistence accross sessions)

EXAMPLE
 If you have used Eclipse or NetBeans then you tend to get pop-ups for classes and functions documentation when you hover above the code ( or press 'F2') which lets you concentrate more on the current context rather than going into the definition of the function or class.
Comment 1 Sam Reed (reedy) 2011-04-06 20:26:24 UTC
You realise there is a Gadget/user side JS to do this?
Comment 2 Kshitiz Sethia 2011-04-06 20:38:42 UTC
No, I have no idea, can you please provide me with the name of the gadget and how to add it?
Comment 3 Bawolff (Brian Wolff) 2011-04-06 23:03:47 UTC
(In reply to comment #2)
> No, I have no idea, can you please provide me with the name of the gadget and
> how to add it?

Its called Lupin's navigational popups. Go to the page [[special:preferences]]. Its under the "gadgets" tab.(You have to be logged in).

(bug 503 is a request to include that in an extension and/or core)

*** This bug has been marked as a duplicate of bug 503 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links